summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-13 15:51:59 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-13 15:51:59 +0200
commit86939047daba141e0cafaf7a03dbe48f4d76c30c (patch)
tree1dabd14316bf641bd394d01224ac72ee01c54dae /sys-apps/duc
parentsys-apps/lnxhc: port to EAPI 7 (diff)
downloadgentoo-86939047daba141e0cafaf7a03dbe48f4d76c30c.tar.gz
gentoo-86939047daba141e0cafaf7a03dbe48f4d76c30c.tar.bz2
gentoo-86939047daba141e0cafaf7a03dbe48f4d76c30c.zip
sys-apps/duc: drop 1.4.1-r1 (EAPI 5)
Signed-off-by: Sam James <sam@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/duc')
-rw-r--r--sys-apps/duc/Manifest1
-rw-r--r--sys-apps/duc/duc-1.4.1-r1.ebuild85
2 files changed, 0 insertions, 86 deletions
diff --git a/sys-apps/duc/Manifest b/sys-apps/duc/Manifest
index 4beb1637a043..018d009adebb 100644
--- a/sys-apps/duc/Manifest
+++ b/sys-apps/duc/Manifest
@@ -1,2 +1 @@
-DIST duc-1.4.1.tar.gz 325689 BLAKE2B 1e23204b60d1dd67eb094c1152c5056d0abc1fc6037a3811df5be18cbc4d61ccd2077b175f8f75559f368e2633476990e0c453cf88cff03c8aa3fc1796a42440 SHA512 88aa8f51651adf019c3a91c83eca308b822ff7569d6f6d30cf91338740ec9b0bd21c4f5dd783cf46c8d67aad6b03ad908cd7ed472e5db6feaf66ee02582d9f88
DIST duc-1.4.3.tar.gz 363507 BLAKE2B 8d4364d48c247d7a83c8c5dd900b1c36ec78c68fa7d090e178a0e3209583e433c2e459d192f65ac350038c7e0d5a57df2c5c0d649cc9f554d7af74ad960c8db5 SHA512 5eb3e862e7003838e012dd1faab507a9b58607b77bd2af70a662005b6e4008ac44d1fb2e17b99da8e42ddfadb1cede2a468144ace7a72c12d0825fc7df4d18cd
diff --git a/sys-apps/duc/duc-1.4.1-r1.ebuild b/sys-apps/duc/duc-1.4.1-r1.ebuild
deleted file mode 100644
index fbabb254f8d7..000000000000
--- a/sys-apps/duc/duc-1.4.1-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit autotools
-
-if [[ "${PV}" == "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/zevv/duc.git"
-else
- KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/zevv/${PN}/releases/download/${PV}/${P}.tar.gz"
-fi
-
-DESCRIPTION="A library and suite of tools for inspecting disk usage"
-HOMEPAGE="https://github.com/zevv/duc"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="cairo gui -leveldb ncurses -sqlite +tokyocabinet X"
-
-REQUIRED_USE="
- ^^ ( tokyocabinet leveldb sqlite )
- X? ( cairo gui )
-"
-
-DEPEND="
- cairo? ( x11-libs/cairo x11-libs/pango )
- gui? (
- X? (
- x11-libs/cairo[X]
- x11-libs/libX11
- x11-libs/pango[X]
- )
- !X? ( >=media-libs/glfw-3.0 )
- )
- leveldb? ( dev-libs/leveldb )
- ncurses? ( sys-libs/ncurses:= )
- sqlite? ( dev-db/sqlite:3 )
- tokyocabinet? ( dev-db/tokyocabinet )
-"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- if [[ "${PV}" == "9999" ]]; then
- git-r3_src_unpack
- else
- unpack ${A}
- fi
-}
-
-src_prepare() {
- sed -i -e "/ldconfig/d" -e "/install-exec-hook/d" Makefile.am || die
-
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myconf=( $(use_enable ncurses ui) )
-
- if use tokyocabinet; then
- myconf+=( --with-db-backend=tokyocabinet )
- elif use leveldb; then
- myconf+=( --with-db-backend=leveldb )
- else
- myconf+=( --with-db-backend=sqlite3 )
- fi
-
- # Necessary logic for cairo
- if use gui && use X; then
- # X backend GUI
- myconf+=( --enable-x11 --disable-opengl --enable-cairo )
- elif use gui; then
- # OpenGL backend GUI
- myconf+=( --disable-x11 --enable-opengl $(use_enable cairo) )
- else
- # No GUI
- myconf+=( $(use_enable cairo) --disable-x11 --disable-opengl )
- fi
-
- econf ${myconf[@]}
-}