summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 09:23:24 +0100
committerSam James <sam@gentoo.org>2022-05-31 09:42:52 +0100
commitf20643d9b4749c5d547748ef46044442a07d480e (patch)
treebae03086169541bef4a9a56935e12f3cda202e0f /sys-apps/fakechroot
parentdev-python/werkzeug: Stabilize 2.1.2 amd64, #848678 (diff)
downloadgentoo-f20643d9b4749c5d547748ef46044442a07d480e.tar.gz
gentoo-f20643d9b4749c5d547748ef46044442a07d480e.tar.bz2
gentoo-f20643d9b4749c5d547748ef46044442a07d480e.zip
sys-apps/fakechroot: add 2.20.1_p2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/fakechroot')
-rw-r--r--sys-apps/fakechroot/Manifest2
-rw-r--r--sys-apps/fakechroot/fakechroot-2.20.1_p2.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/fakechroot/Manifest b/sys-apps/fakechroot/Manifest
index 0429ed76685c..47334d301bf1 100644
--- a/sys-apps/fakechroot/Manifest
+++ b/sys-apps/fakechroot/Manifest
@@ -1 +1,3 @@
DIST fakechroot-2.20.1.tar.gz 504343 BLAKE2B 73459895319c1fd6297ab455e0d15f4b9985f433d958598d8581a35268e4df0f631b39d026061fe5c00ec6b805f3bf4f5f261039b93176db460b6f936c0de1b8 SHA512 9ddc715ff5c550b700c2384284c9f0cf6c2a99353a06d8e4c3b8363f4affdf9a11757ed5d1c9b85c83499b3bec054544290508a20f2ee16d46e66dc824a924ed
+DIST fakechroot_2.20.1+ds-2.debian.tar.xz 16120 BLAKE2B f4fe6943ca8e0f2bc68cc9d97af1195c34b8700b37838ced773e1452352d46806ebd31dbd6439121fa625ce74148d749e5064fe347ea5b1fa2e41c4e1b1a9867 SHA512 060448526eb7ac89b53984c582bcfffb641abdf4e7696e0033610343039012e6d459fb6682b4c1caa12bfcb91d515dfc4123ff3f1be3468d9db1a58ab9a8b415
+DIST fakechroot_2.20.1+ds.orig.tar.xz 88680 BLAKE2B 5e119eb6d7acee1f45bfc267e15b228624bbc5e29ebb19bcb61c4684719df4ce751c315423c27bceb0e2f97bcd491daa16d76f6b964842dcaddb90761dca092e SHA512 c61960b4fb03e65d7678511ae01a6f977d7f5584e81ee15a283f98da102dfc85d923265936443c7e9e208b62bb2147e8ae21a0ac62acf5bd8432775a4f6e723e
diff --git a/sys-apps/fakechroot/fakechroot-2.20.1_p2.ebuild b/sys-apps/fakechroot/fakechroot-2.20.1_p2.ebuild
new file mode 100644
index 000000000000..6e11e6023fc4
--- /dev/null
+++ b/sys-apps/fakechroot/fakechroot-2.20.1_p2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Upstream seem to be kind of dead, so using Debian's patches.
+DESCRIPTION="Provide a faked chroot environment without requiring root privileges"
+HOMEPAGE="https://github.com/dex4er/fakechroot"
+if [[ ${PV} == *_p* ]] ; then
+ inherit autotools
+
+ SRC_URI="mirror://debian/pool/main/f/${PN}/${PN}_$(ver_cut 1-3)+ds.orig.tar.xz"
+ SRC_URI+=" mirror://debian/pool/main/f/${PN}/${PN}_$(ver_cut 1-3)+ds-$(ver_cut 5).debian.tar.xz"
+ S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+else
+ SRC_URI="https://github.com/dex4er/${PN}/releases/download/${PV}/${P}.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == *_p* ]] ; then
+ if [[ -d "${WORKDIR}"/debian/patches ]] ; then
+ eapply $(sed -e 's:^:../debian/patches/:' ../debian/patches/series || die)
+ fi
+
+ eautoreconf
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}