summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-26 08:23:23 +0000
committerSam James <sam@gentoo.org>2022-12-26 08:32:59 +0000
commit4092b355dffe2f27ce6594f48a21f5680cdb273a (patch)
treeb910299f8f75734aa300214d8c1c2a276b6813d2 /sys-apps/fakeroot
parentsys-apps/cracklib-words: drop 2.9.7 (diff)
downloadgentoo-4092b355dffe2f27ce6594f48a21f5680cdb273a.tar.gz
gentoo-4092b355dffe2f27ce6594f48a21f5680cdb273a.tar.bz2
gentoo-4092b355dffe2f27ce6594f48a21f5680cdb273a.zip
sys-apps/fakeroot: drop 1.29
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/fakeroot')
-rw-r--r--sys-apps/fakeroot/Manifest1
-rw-r--r--sys-apps/fakeroot/fakeroot-1.29.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/sys-apps/fakeroot/Manifest b/sys-apps/fakeroot/Manifest
index c72cba19a962..9ba8c068804a 100644
--- a/sys-apps/fakeroot/Manifest
+++ b/sys-apps/fakeroot/Manifest
@@ -1,3 +1,2 @@
DIST fakeroot_1.27.orig.tar.gz 544301 BLAKE2B 5e887d43c8bedaecbe51eb7f606d6bace3a9f191a7cf4be32362e1ba97e438413f04ed644532d3a386a46f3a569bf0104c4f38272e5ff46e3705c17896fef972 SHA512 cd98b8cd1064a5a11c6f25bc1d9cb1fb1bf0787f50772fead301470d1769c08a89a1510402b099af334d9f126cea5d3bd5d73e27fb91b5afc1ceebeb9ec3f926
-DIST fakeroot_1.29.orig.tar.gz 549383 BLAKE2B ccdc5e793ce6a6adc9ffdb9346045e144dcd802ca8ffcbd188010ab759861d0e0ae81b3baa256546398c2ddab31d1f795f327130cb1f7bb1c3eee07e7282e94b SHA512 d0f02c36cfe4e24f1588894bd732ff5a6fc0e921695236311019a63280efdca8568f2e974672145eb7c4d57f64a15a77d23658fd4aeef2ca24901fc66259e4dc
DIST fakeroot_1.30.1.orig.tar.gz 551219 BLAKE2B e8f7e69d5be0e8e87a365f59f61a848ade0a10ab926bf10262ffd32f126fa0ade92be66f377ea8aba907f6a1ece85b68544ee52b08c45287853d37ce492cc015 SHA512 a7ed2d86c7adf3e662e79b977c23247bf942fddf98a11c370389f0c43dd51e8e038c8489d0bb583ba90427c832fa36b244880034d25cb475f27ad68a5d7cde0c
diff --git a/sys-apps/fakeroot/fakeroot-1.29.ebuild b/sys-apps/fakeroot/fakeroot-1.29.ebuild
deleted file mode 100644
index 523ceccc2c7c..000000000000
--- a/sys-apps/fakeroot/fakeroot-1.29.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PLOCALES="de es fr nl pt sv"
-inherit autotools flag-o-matic plocale
-
-DESCRIPTION="A fake root environment by means of LD_PRELOAD and SysV IPC (or TCP) trickery"
-HOMEPAGE="https://packages.qa.debian.org/f/fakeroot.html"
-SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${P/-/_}.orig.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="acl debug nls test"
-RESTRICT="!test? ( test )"
-
-DEPEND="sys-libs/libcap
- acl? ( sys-apps/acl )
- test? ( app-arch/sharutils )"
-BDEPEND="nls? ( app-text/po4a )"
-
-DOCS=( AUTHORS BUGS DEBUG README doc/README.saving )
-
-src_prepare() {
- default
-
- disable_locale() {
- local locale=${1}
-
- sed -i -e "s: ${locale}::" doc/po4a/po4a.cfg doc/Makefile.am || die
- }
-
- plocale_find_changes doc/po4a/po '' '.po'
- plocale_for_each_disabled_locale disable_locale
-
- # We could make this conditional and disable the autodependency in
- # autotools.eclass but it'd make it too easy for NLS builds to be broken
- # and us not realise.
- eautoreconf
-}
-
-src_configure() {
- export ac_cv_header_sys_acl_h=$(usex acl)
- use acl || export ac_cv_search_acl_get_fd=no # bug 759568
- use debug && append-cppflags -DLIBFAKEROOT_DEBUGGING
-
- # https://bugs.gentoo.org/834445
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=101270
- filter-flags -fno-semantic-interposition
-
- econf --disable-static
-}
-
-src_compile() {
- local enabled_locales=$(plocale_get_locales)
-
- if use nls && [[ -n ${enabled_locales} ]] ; then
- # Create translated man pages
- pushd doc >/dev/null || die
- po4a -v -k 0 --variable "srcdir=${S}/doc/" po4a/po4a.cfg || die
- popd >/dev/null || die
- fi
-
- default
-}
-
-src_install() {
- default
-
- # no static archives
- find "${ED}" -name '*.la' -delete || die
-}