summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-02-03 03:11:43 +0000
committerSam James <sam@gentoo.org>2022-02-03 03:11:43 +0000
commit3d7aed29b24c08fb3425477670e6279482658c7a (patch)
tree336c6332d71c6517760d9e41bd3167ff36c3efeb /sys-apps/findutils
parentdev-util/byacc: add 20220128 (diff)
downloadgentoo-3d7aed29b24c08fb3425477670e6279482658c7a.tar.gz
gentoo-3d7aed29b24c08fb3425477670e6279482658c7a.tar.bz2
gentoo-3d7aed29b24c08fb3425477670e6279482658c7a.zip
sys-apps/findutils: add 4.9.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/findutils')
-rw-r--r--sys-apps/findutils/Manifest1
-rw-r--r--sys-apps/findutils/findutils-4.9.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-apps/findutils/Manifest b/sys-apps/findutils/Manifest
index 4c41ac69db44..4c3aa27c8258 100644
--- a/sys-apps/findutils/Manifest
+++ b/sys-apps/findutils/Manifest
@@ -1 +1,2 @@
DIST findutils-4.8.0.tar.xz 1983096 BLAKE2B e1f030ef11c252d33e92bf58dca20a6dd681938aad74b1bbd2bf64a0d175d64c8edac1edce71d13379e04a27e47ffa6099e105bb731957cf5247ffe01d856538 SHA512 eaa2da304dbeb2cd659b9210ac37da1bde4cd665c12a818eca98541c5ed5cba1050641fc0c39c0a446a5a7a87a8d654df0e0e6b0cee21752ea485188c9f1071e
+DIST findutils-4.9.0.tar.xz 2046252 BLAKE2B 3ada8903fc552ad2e580a7b631a4b9d941935b3f4231029564c6f2b7b10ba6f2244e2de57f6d79268c5e0481a193f64edbbae637e7a51ae6f495e3eefabf52c9 SHA512 ba4844f4403de0148ad14b46a3dbefd5a721f6257c864bf41a6789b11705408524751c627420b15a52af95564d8e5b52f0978474f640a62ab86a41d20cf14be9
diff --git a/sys-apps/findutils/findutils-4.9.0.ebuild b/sys-apps/findutils/findutils-4.9.0.ebuild
new file mode 100644
index 000000000000..c57ebc1c2ccf
--- /dev/null
+++ b/sys-apps/findutils/findutils-4.9.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit flag-o-matic python-any-r1
+
+DESCRIPTION="GNU utilities for finding files"
+HOMEPAGE="https://www.gnu.org/software/findutils/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls selinux static test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="selinux? ( sys-libs/libselinux )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ test? ( ${PYTHON_DEPS} )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # Don't build or install locate because it conflicts with mlocate,
+ # which is a secure version of locate. See bug 18729
+ sed \
+ -e '/^SUBDIRS/s@locate@@' \
+ -e '/^built_programs/s@ frcode locate updatedb@@' \
+ -i Makefile.in || die
+
+ default
+}
+
+src_configure() {
+ if use static; then
+ append-flags -pthread
+ append-ldflags -static
+ fi
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00050.html
+ # https://lists.gnu.org/archive/html/bug-findutils/2021-01/msg00051.html
+ append-cppflags '-D__nonnull\(X\)='
+ fi
+
+ local myeconfargs=(
+ --with-packager="Gentoo"
+ --with-packager-version="${PVR}"
+ --with-packager-bug-reports="https://bugs.gentoo.org/"
+ $(use_enable nls)
+ $(use_with selinux)
+ --libexecdir='$(libdir)'/find
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # We don't build locate, but the docs want a file in there.
+ emake -C locate dblocation.texi
+ default
+}