summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/heirloom-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/heirloom-tools')
-rw-r--r--sys-apps/heirloom-tools/Manifest1
-rw-r--r--sys-apps/heirloom-tools/heirloom-tools-070715.ebuild42
-rw-r--r--sys-apps/heirloom-tools/metadata.xml8
3 files changed, 51 insertions, 0 deletions
diff --git a/sys-apps/heirloom-tools/Manifest b/sys-apps/heirloom-tools/Manifest
new file mode 100644
index 000000000000..1b23e0ac46fd
--- /dev/null
+++ b/sys-apps/heirloom-tools/Manifest
@@ -0,0 +1 @@
+DIST heirloom-070715.tar.bz2 1000080 SHA256 eb33f70bcc019b1d0e0a41f1d7552d45c57a16272e4e1c48634ec3e44496a30f SHA512 0b30b0f4c4c92a10ee2da263ea44666f445d96bac86ca4afb7bbb50d8278986e4145a7bcdf3ed9f75611bb956e93e16fc0e19874498ce3ae1a00e6fbb4f910c9 WHIRLPOOL be19c6833970b343f952f28821dea4f3571f6f348841a23b793ea587be65930a7e5fd41fe0ba2b617be343ea520d626e61cb98b7c42e0fe0e78b423c0be3ab83
diff --git a/sys-apps/heirloom-tools/heirloom-tools-070715.ebuild b/sys-apps/heirloom-tools/heirloom-tools-070715.ebuild
new file mode 100644
index 000000000000..aded44391e41
--- /dev/null
+++ b/sys-apps/heirloom-tools/heirloom-tools-070715.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic toolchain-funcs
+
+# slightly broken
+RESTRICT="test"
+
+DESCRIPTION="Heirloom toolchest - original Unix tools"
+HOMEPAGE="http://heirloom.sourceforge.net/tools.html"
+SRC_URI="http://downloads.sourceforge.net/project/heirloom/heirloom/${PV}/heirloom-${PV}.tar.bz2"
+
+LICENSE="CDDL GPL-2 LGPL-2.1 9base ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/ed
+ sys-libs/zlib[static-libs]"
+RDEPEND=""
+
+S="${WORKDIR}/heirloom-${PV}"
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake -j1 ||die
+}
+
+src_install() {
+ # we don't want to strip here, so use "true" as noop
+ emake STRIP="true" ROOT="${D}" -j1 install || die
+}
+
+pkg_postinst() {
+ elog "You may want to add /usr/5bin or /usr/ucb to \$PATH"
+ elog "to enable using the apps of heirloom toolchest by default."
+ elog "Man pages are installed in /usr/share/man/5man/"
+ elog "You may need to set \$MANPATH to access them."
+}
diff --git a/sys-apps/heirloom-tools/metadata.xml b/sys-apps/heirloom-tools/metadata.xml
new file mode 100644
index 000000000000..24cbb90cf0c4
--- /dev/null
+++ b/sys-apps/heirloom-tools/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>patrick@gentoo.org</email>
+ <name>Patrick Lauer</name>
+ </maintainer>
+</pkgmetadata>