summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-12 04:56:15 +0100
committerSam James <sam@gentoo.org>2022-08-12 15:21:40 +0100
commit384a04f784315751ea08f855ebc1ca3190fed70a (patch)
treeee388a2d867d4cf5d5cd7ea6e230710d5e24eff2 /sys-apps/help2man
parentapp-accessibility/speech-dispatcher: add missing help2man BDEPEND (diff)
downloadgentoo-384a04f784315751ea08f855ebc1ca3190fed70a.tar.gz
gentoo-384a04f784315751ea08f855ebc1ca3190fed70a.tar.bz2
gentoo-384a04f784315751ea08f855ebc1ca3190fed70a.zip
sys-apps/help2man: add 1.49.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/help2man')
-rw-r--r--sys-apps/help2man/Manifest1
-rw-r--r--sys-apps/help2man/help2man-1.49.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-apps/help2man/Manifest b/sys-apps/help2man/Manifest
index 9282e6ae0017..184c445c002a 100644
--- a/sys-apps/help2man/Manifest
+++ b/sys-apps/help2man/Manifest
@@ -1 +1,2 @@
DIST help2man-1.48.5.tar.xz 204672 BLAKE2B 6d96f5f65f8c637d524e5c373f2b89f114adf544c1d3508a9cb51115279b9bf6399c8ebb0a8d831de12ef8cdaca40b6e75412a221efc5d2dd1794e9c9643196f SHA512 800eb0daa9daef8e423d52ede55eee2960122ea0269865295afada4cf4fcc1c6791da8429c3a57c0fc1bf0a14c8a77953952325413a8faa5dd07b1bc5bc0edd1
+DIST help2man-1.49.2.tar.xz 225428 BLAKE2B 62db47a5915432093991f060390a62ebf2d1e5e6e78f7142d0cd5f8a273a1fd74f55de4b3ead5c1071aaf4de084e62782981a1d888b8a8b76da9c07e0cda20ea SHA512 cb8f9f923263d7160a27a7924ae559aba93d7258167888eb9e0e3e97a2014297b8d739b2bb7869acbf586354d099bd91d85f8208b901bce5ba0c5ad4b6abd6d5
diff --git a/sys-apps/help2man/help2man-1.49.2.ebuild b/sys-apps/help2man/help2man-1.49.2.ebuild
new file mode 100644
index 000000000000..bd9be868fe32
--- /dev/null
+++ b/sys-apps/help2man/help2man-1.49.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="GNU utility to convert program --help output to a man page"
+HOMEPAGE="https://www.gnu.org/software/help2man/ https://salsa.debian.org/bod/help2man"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="dev-lang/perl
+ nls? ( dev-perl/Locale-gettext )"
+DEPEND="${RDEPEND}"
+
+# bug #385753
+DOCS=( debian/changelog NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.46.1-linguas.patch
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ sed -i \
+ -e 's/-shared/-bundle/' \
+ Makefile.in || die
+ fi
+
+ default
+}
+
+src_configure() {
+ # Disable gettext requirement as the release includes the gmo files, bug #555018
+ local myeconfargs=(
+ ac_cv_path_MSGFMT=$(type -P false)
+ $(use_enable nls)
+ )
+
+ econf "${myeconfargs[@]}"
+}