summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-28 19:03:44 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-03-28 19:03:44 +0200
commit090dad68f3f630c60985b077431c1a4e5f380cc4 (patch)
tree1f2817d1346ab366e3657dbe07d63c8efc74b5cf /sys-apps/hw-probe
parentgames-server/bedrock-server: drop 1.18.2.03 (diff)
downloadgentoo-090dad68f3f630c60985b077431c1a4e5f380cc4.tar.gz
gentoo-090dad68f3f630c60985b077431c1a4e5f380cc4.tar.bz2
gentoo-090dad68f3f630c60985b077431c1a4e5f380cc4.zip
sys-apps/hw-probe: add 1.6.3
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.3.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index a9311d02120d..16fe42a46a1c 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1 +1,2 @@
DIST hw-probe-1.6.2.tar.gz 163183 BLAKE2B f9b8d405e59f7799dd665b62362fe8f2b9fe45491d43249ab61ef0fa5ea4d83671ac0dbeef622c68f7c581eef8cd3aa33e6c8bbd46d5488a9c1f4781c820453d SHA512 8a7bf5254f24cc3a1ca19039a00de312f1400f34eaa0459fbff665221940abf60396e5d9e95b4a021e7f5fb9c54254b8c50d0d0b125fc60a0a7f5c7a57edf68c
+DIST hw-probe-1.6.3.tar.gz 161938 BLAKE2B b4c43846411452a580ec4ea1743d3779fdfcf74636c62be5d66bbebe087a6355141f73b3da500cc36eba4dfba322ce19931cfd7023b395134b2fad940785cbff SHA512 b9898603b3bc15bc9d26be8511e64a776b51c8bfdfa6b62d5ca550d2663df8a7a2e3f423023ad8b221b0bc81ac413266ecd9e5fed618dc9967994523dcc7dd0a
diff --git a/sys-apps/hw-probe/hw-probe-1.6.3.ebuild b/sys-apps/hw-probe/hw-probe-1.6.3.ebuild
new file mode 100644
index 000000000000..89965032f4b0
--- /dev/null
+++ b/sys-apps/hw-probe/hw-probe-1.6.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature readme.gentoo-r1
+
+DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
+HOMEPAGE="https://github.com/linuxhw/hw-probe/"
+SRC_URI="https://github.com/linuxhw/hw-probe/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Digest-SHA1
+ net-misc/curl
+ sys-apps/dmidecode
+ sys-apps/edid-decode
+ sys-apps/hwinfo
+ sys-apps/pciutils
+ sys-apps/smartmontools
+ sys-apps/usbutils
+ virtual/perl-Data-Dumper
+"
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ default
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+
+ optfeature "showing Machine Check Exceptions." app-admin/mcelog
+ optfeature "showing additional I/O statistics." app-admin/sysstat
+ optfeature "showing display data channel (ddc) information." app-misc/ddcutil
+ optfeature "showing smart card (reader) information." dev-libs/opensc
+ optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
+ optfeature "showing information of attached scanners." media-gfx/sane-backends
+ optfeature "showing GPU information provided by MESA." media-libs/mesa
+ optfeature "showing zeroconf statistics." net-dns/avahi
+ optfeature "showing HP printer statistics." net-print/hplip
+ optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
+ optfeature "showing additional CPU capabilities." sys-apps/cpuid
+ optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
+ optfeature "showing available I2C sensors." sys-apps/i2c-tools
+ optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
+ optfeature "showing information about tested memory for faults." sys-apps/memtester
+ optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
+ optfeature "showing systemd boot process information." sys-apps/systemd
+ optfeature "showing ACPI statistics and tables." sys-power/iasl
+ optfeature "showing information about NUMA." sys-process/numactl
+ optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
+ optfeature "showing available Xinput devices." x11-apps/xinput
+}