summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-03-07 22:22:32 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-03-07 22:27:04 +0100
commitd4a044fc6d9bcbcfed3393e08e2f075bb41195c4 (patch)
treeae4210194731918af59d9b401640356ee4c1a96a /sys-apps/hw-probe
parentsys-apps/hw-probe: x86 stable (diff)
downloadgentoo-d4a044fc6d9bcbcfed3393e08e2f075bb41195c4.tar.gz
gentoo-d4a044fc6d9bcbcfed3393e08e2f075bb41195c4.tar.bz2
gentoo-d4a044fc6d9bcbcfed3393e08e2f075bb41195c4.zip
sys-apps/hw-probe: drop 1.6
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/hw-probe')
-rw-r--r--sys-apps/hw-probe/Manifest1
-rw-r--r--sys-apps/hw-probe/hw-probe-1.6.ebuild67
2 files changed, 0 insertions, 68 deletions
diff --git a/sys-apps/hw-probe/Manifest b/sys-apps/hw-probe/Manifest
index dcd87631b346..a9311d02120d 100644
--- a/sys-apps/hw-probe/Manifest
+++ b/sys-apps/hw-probe/Manifest
@@ -1,2 +1 @@
DIST hw-probe-1.6.2.tar.gz 163183 BLAKE2B f9b8d405e59f7799dd665b62362fe8f2b9fe45491d43249ab61ef0fa5ea4d83671ac0dbeef622c68f7c581eef8cd3aa33e6c8bbd46d5488a9c1f4781c820453d SHA512 8a7bf5254f24cc3a1ca19039a00de312f1400f34eaa0459fbff665221940abf60396e5d9e95b4a021e7f5fb9c54254b8c50d0d0b125fc60a0a7f5c7a57edf68c
-DIST hw-probe-1.6.tar.gz 158879 BLAKE2B 96d36be283d497df8aed944f3ba14c620e3abc7d3dd728c274f3ebaca3f064d1ac92bd4d47cbae51500264d785feda25082950fde6fdbd6c1b35f48736015659 SHA512 9ef51c0acc450d1f2073c03885e097231a745a456ae384825c56804f94c62ac85bf4c795627e6ea738636fa83d50d7ef60e20c6dd9621247ff06c51461d91249
diff --git a/sys-apps/hw-probe/hw-probe-1.6.ebuild b/sys-apps/hw-probe/hw-probe-1.6.ebuild
deleted file mode 100644
index ebc0645f72fc..000000000000
--- a/sys-apps/hw-probe/hw-probe-1.6.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MY_PV="${PV/_/-}"
-MY_PV_BETA="${MY_PV/2/}"
-
-inherit optfeature readme.gentoo-r1
-
-DESCRIPTION="A tool to probe for hardware, check it's operability and find drivers"
-HOMEPAGE="https://github.com/linuxhw/hw-probe/"
-SRC_URI="https://github.com/linuxhw/hw-probe/archive/${MY_PV_BETA}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV_BETA}"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-
-RDEPEND="
- dev-lang/perl
- dev-perl/Digest-SHA1
- net-misc/curl
- sys-apps/dmidecode
- sys-apps/edid-decode
- sys-apps/hwinfo
- sys-apps/pciutils
- sys-apps/smartmontools
- sys-apps/usbutils
- virtual/perl-Data-Dumper
-"
-
-src_compile() {
- :;
-}
-
-src_install() {
- default
-
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-
- optfeature "showing Machine Check Exceptions." app-admin/mcelog
- optfeature "showing additional I/O statistics." app-admin/sysstat
- optfeature "showing display data channel (ddc) information." app-misc/ddcutil
- optfeature "showing smart card (reader) information." dev-libs/opensc
- optfeature "showing Vulkan GPU hardware information." dev-util/vulkan-tools
- optfeature "showing information of attached scanners." media-gfx/sane-backends
- optfeature "showing GPU information provided by MESA." media-libs/mesa
- optfeature "showing zeroconf statistics." net-dns/avahi
- optfeature "showing HP printer statistics." net-print/hplip
- optfeature "showing status about rfkill switches on communication devices." net-wireless/rfkill
- optfeature "showing additional CPU capabilities." sys-apps/cpuid
- optfeature "showing hard disk (HDD, SSD, ..) capabilities." sys-apps/hdparm
- optfeature "showing available I2C sensors." sys-apps/i2c-tools
- optfeature "showing additional hardware and system information detected by inxi." sys-apps/inxi
- optfeature "showing information about tested memory for faults." sys-apps/memtester
- optfeature "showing 'Plug & Play' devices." sys-apps/pnputils
- optfeature "showing systemd boot process information." sys-apps/systemd
- optfeature "showing ACPI statistics and tables." sys-power/iasl
- optfeature "showing information about NUMA." sys-process/numactl
- optfeature "showing additional GPU information provided by MESA progs." x11-apps/mesa-progs
- optfeature "showing available Xinput devices." x11-apps/xinput
-}