summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-04-29 12:32:09 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-04-29 12:32:51 -0400
commit7bd9362ed4933d83eaad0c20c44fd3f0cf3af77d (patch)
tree0c613889751e93180831c64362534da2eafdf5f0 /sys-apps/install-xattr
parentprofiles/base/package.use.mask: drop system-libvpx mask on mozilla ebuilds (diff)
downloadgentoo-7bd9362ed4933d83eaad0c20c44fd3f0cf3af77d.tar.gz
gentoo-7bd9362ed4933d83eaad0c20c44fd3f0cf3af77d.tar.bz2
gentoo-7bd9362ed4933d83eaad0c20c44fd3f0cf3af77d.zip
sys-apps/install-xattr: fix bug #581552
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-apps/install-xattr')
-rw-r--r--sys-apps/install-xattr/install-xattr-0.5-r1.ebuild3
-rw-r--r--sys-apps/install-xattr/install-xattr-9999.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-apps/install-xattr/install-xattr-0.5-r1.ebuild b/sys-apps/install-xattr/install-xattr-0.5-r1.ebuild
index 3e98386cc75b..027f7eecac1e 100644
--- a/sys-apps/install-xattr/install-xattr-0.5-r1.ebuild
+++ b/sys-apps/install-xattr/install-xattr-0.5-r1.ebuild
@@ -11,7 +11,7 @@ inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
+ inherit git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -23,6 +23,7 @@ SLOT="0"
src_prepare() {
tc-export CC
+ eapply_user
}
src_compile() {
diff --git a/sys-apps/install-xattr/install-xattr-9999.ebuild b/sys-apps/install-xattr/install-xattr-9999.ebuild
index d64e0c47d619..027f7eecac1e 100644
--- a/sys-apps/install-xattr/install-xattr-9999.ebuild
+++ b/sys-apps/install-xattr/install-xattr-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
DESCRIPTION="Wrapper to coreutil's install to preserve Filesystem Extended Attributes"
HOMEPAGE="https://dev.gentoo.org/~blueness/install-xattr/"
@@ -11,7 +11,7 @@ inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://anongit.gentoo.org/proj/elfix.git"
- inherit git-2
+ inherit git-r3
else
SRC_URI="https://dev.gentoo.org/~blueness/install-xattr/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
@@ -23,6 +23,7 @@ SLOT="0"
src_prepare() {
tc-export CC
+ eapply_user
}
src_compile() {