summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2024-04-12 10:46:13 -0700
committerPatrick McLean <chutzpah@gentoo.org>2024-04-12 10:46:13 -0700
commitfa4b2ce183709b43eb99927af4b18a2e4aede276 (patch)
treebecd1e277212cf7acd3e60da4a5497cc31cf41b5 /sys-apps/iproute2
parentsys-apps/iproute2: Make sure that CFLAGS is in LDFLAGS (diff)
downloadgentoo-fa4b2ce183709b43eb99927af4b18a2e4aede276.tar.gz
gentoo-fa4b2ce183709b43eb99927af4b18a2e4aede276.tar.bz2
gentoo-fa4b2ce183709b43eb99927af4b18a2e4aede276.zip
sys-apps/iproute2: Sync 9999 with 6.8.0-r1
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-apps/iproute2')
-rw-r--r--sys-apps/iproute2/iproute2-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-apps/iproute2/iproute2-9999.ebuild b/sys-apps/iproute2/iproute2-9999.ebuild
index f8e1ae63ceec..bfc78c186a70 100644
--- a/sys-apps/iproute2/iproute2-9999.ebuild
+++ b/sys-apps/iproute2/iproute2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit edo toolchain-funcs
+inherit edo toolchain-funcs flag-o-matic
if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/shemminger/iproute2.git"
@@ -104,6 +104,11 @@ src_configure() {
fi
popd >/dev/null || die
+ # build system does not pass CFLAGS to LDFLAGS, as is recommended by GCC upstream
+ # https://gcc.gnu.org/onlinedocs/gcc/Optimize-Options.html#index-flto
+ # https://bugs.gentoo.org/929233
+ append-ldflags ${CFLAGS}
+
# run "configure" script first which will create "config.mk"...
# Using econf breaks since 5.14.0 (a9c3d70d902a0473ee5c13336317006a52ce8242)
edo ./configure --color=auto --libbpf_force $(usex bpf on off)