summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/isapnptools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/isapnptools')
-rw-r--r--sys-apps/isapnptools/Manifest1
-rw-r--r--sys-apps/isapnptools/files/isapnp.rc26
-rw-r--r--sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch41
-rw-r--r--sys-apps/isapnptools/files/isapnptools-1.27-include.patch10
-rw-r--r--sys-apps/isapnptools/isapnptools-1.27.ebuild33
-rw-r--r--sys-apps/isapnptools/metadata.xml5
6 files changed, 116 insertions, 0 deletions
diff --git a/sys-apps/isapnptools/Manifest b/sys-apps/isapnptools/Manifest
new file mode 100644
index 000000000000..a33cf68d0999
--- /dev/null
+++ b/sys-apps/isapnptools/Manifest
@@ -0,0 +1 @@
+DIST isapnptools-1.27.tgz 499639 SHA256 32b1af6188a2b6fc432ab10c58a97985836ffa8d4762a8e9aae9b442a44466f4
diff --git a/sys-apps/isapnptools/files/isapnp.rc b/sys-apps/isapnptools/files/isapnp.rc
new file mode 100644
index 000000000000..1c8eb5509b4c
--- /dev/null
+++ b/sys-apps/isapnptools/files/isapnp.rc
@@ -0,0 +1,26 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+check_config() {
+ if [ ! -e /etc/isapnp.conf ] ; then
+ eerror "You need an /etc/isapnp.conf file first"
+ eerror "Theres a sample in docs/isapnptools/txt"
+ return 1
+ fi
+ if [ ! -x /sbin/isapnp ] ; then
+ eerror "You're missing /sbin/isapnp; emerge sys-apps/isapnptools"
+ return 1
+ fi
+
+ return 0
+}
+
+start() {
+ check_config || return 1
+
+ ebegin "Configuring ISA PnP devices"
+ /sbin/isapnp /etc/isapnp.conf
+ eend $?
+}
diff --git a/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch b/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch
new file mode 100644
index 000000000000..3d1f2cee9f80
--- /dev/null
+++ b/sys-apps/isapnptools/files/isapnptools-1.26-gcc.patch
@@ -0,0 +1,41 @@
+http://bugs.gentoo.org/117333
+
+--- isapnptools/src/isapnp_main.l
++++ isapnptools/src/isapnp_main.l
+@@ -363,7 +363,6 @@
+ return 0;
+ }
+
+-static unsigned char serial_identifier[NUM_CARDS+1][IDENT_LEN];
+ static char *boardid[NUM_CARDS+1];
+ static unsigned long serno[NUM_CARDS+1];
+
+--- isapnptools/src/callbacks.c
++++ isapnptools/src/callbacks.c
+@@ -49,6 +49,7 @@
+ #include <isapnp/callbacks.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <errno.h>
+ #include <string.h>
+
+--- isapnptools/src/resource.c
++++ isapnptools/src/resource.c
+@@ -12,6 +12,7 @@
+ alloc_in_range_list() reordered to handle source name by P.Fox
+ */
+
++#define _GNU_SOURCE
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+ #endif
+@@ -285,7 +286,7 @@
+ void allocate_pci_resources( void )
+ {
+ char *line = 0;
+- int lineMax = 0;
++ size_t lineMax = 0;
+
+ FILE *fp = fopen( "/proc/bus/pci/devices", "rt" );
+ if( !fp )
diff --git a/sys-apps/isapnptools/files/isapnptools-1.27-include.patch b/sys-apps/isapnptools/files/isapnptools-1.27-include.patch
new file mode 100644
index 000000000000..a736ccc1eb9d
--- /dev/null
+++ b/sys-apps/isapnptools/files/isapnptools-1.27-include.patch
@@ -0,0 +1,10 @@
+--- src/callbacks.c.org 2001-05-15 22:37:04.000000000 +0200
++++ src/callbacks.c 2011-06-15 05:21:32.292819557 +0200
+@@ -51,6 +51,7 @@
+ #include <stdio.h>
+ #include <errno.h>
+ #include <string.h>
++#include <stdlib.h> /* exit() */
+
+ /****************************************************************************/
+
diff --git a/sys-apps/isapnptools/isapnptools-1.27.ebuild b/sys-apps/isapnptools/isapnptools-1.27.ebuild
new file mode 100644
index 000000000000..84dafbcaca4c
--- /dev/null
+++ b/sys-apps/isapnptools/isapnptools-1.27.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Tools for configuring ISA PnP devices"
+HOMEPAGE="http://www.roestock.demon.co.uk/isapnptools/"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/hardware/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-include.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodir /sbin
+ mv "${D}"/usr/sbin/isapnp "${D}"/sbin/ || die
+
+ dodoc AUTHORS ChangeLog README NEWS
+ docinto txt
+ dodoc doc/README* doc/*.txt test/*.txt
+ dodoc etc/isapnp.*
+
+ newinitd "${FILESDIR}"/isapnp.rc isapnp
+}
diff --git a/sys-apps/isapnptools/metadata.xml b/sys-apps/isapnptools/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/isapnptools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>