summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/makedev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/makedev')
-rw-r--r--sys-apps/makedev/Manifest1
-rw-r--r--sys-apps/makedev/files/makedev-3.23.1-headers.patch12
-rw-r--r--sys-apps/makedev/makedev-3.23.1.ebuild53
-rw-r--r--sys-apps/makedev/metadata.xml5
4 files changed, 71 insertions, 0 deletions
diff --git a/sys-apps/makedev/Manifest b/sys-apps/makedev/Manifest
new file mode 100644
index 000000000000..7bd3ed305330
--- /dev/null
+++ b/sys-apps/makedev/Manifest
@@ -0,0 +1 @@
+DIST MAKEDEV-3.23-1.tar.gz 122613 SHA256 46cebf1e5e36838a5637bdd2b7af07eb1773599e1288c2d1c777e2875d721965 SHA512 5ca82cdcc4544042ede552370acf6266929fa34d177bd8e831573ccc1c57e06ec87766b9e60a686ec1449b204ae0ac3c048eab32b57ce8d610366219d3a77dbc WHIRLPOOL fa11a2e0a143755af7c877171f67a95f6ea566cf0e9e8218bd412b98e75e50763e06cfc1c659527596a50f39cc905a3484f2fd5578a96d6389c7dc22ecadd103
diff --git a/sys-apps/makedev/files/makedev-3.23.1-headers.patch b/sys-apps/makedev/files/makedev-3.23.1-headers.patch
new file mode 100644
index 000000000000..fac3fb1b711c
--- /dev/null
+++ b/sys-apps/makedev/files/makedev-3.23.1-headers.patch
@@ -0,0 +1,12 @@
+http://bugs.gentoo.org/339674
+
+--- a/MAKEDEV-3.23/sel.h
++++ b/MAKEDEV-3.23/sel.h
+@@ -18,6 +18,7 @@
+ */
+
+ #ifdef MAKEDEV_SELINUX
++#include <limits.h>
+ #include <selinux/selinux.h>
+ static char secontextname[PATH_MAX + 2];
+ static char secontextflag[PATH_MAX + 7];
diff --git a/sys-apps/makedev/makedev-3.23.1.ebuild b/sys-apps/makedev/makedev-3.23.1.ebuild
new file mode 100644
index 000000000000..6cc925cf58af
--- /dev/null
+++ b/sys-apps/makedev/makedev-3.23.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_PN="MAKEDEV"
+MY_VER=${PV%.*}
+MY_REL=${PV#${MY_VER}.}
+MY_P="${MY_PN}-${MY_VER}"
+DESCRIPTION="program used for creating device files in /dev"
+HOMEPAGE="http://people.redhat.com/nalin/MAKEDEV/"
+SRC_URI="http://people.redhat.com/nalin/MAKEDEV/${MY_P}-${MY_REL}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
+IUSE="build selinux"
+
+RDEPEND="!<sys-apps/baselayout-2.0.0_rc"
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-headers.patch #339674
+}
+
+src_compile() {
+ use selinux && export SELINUX=1
+ emake CC="$(tc-getCC)" OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # set devdir to makedevdir so we dont have to worry about /dev
+ emake install DESTDIR="${D}" makedevdir=/sbin devdir=/sbin || die
+ dodoc *.txt
+ keepdir /dev
+}
+
+pkg_postinst() {
+ if use build ; then
+ # set up a base set of nodes to make recovery easier #368597
+ "${ROOT}"/sbin/MAKEDEV -c "${ROOT}"/etc/makedev.d \
+ -d "${ROOT}"/dev console hda input ptmx std sd tty
+ # trim useless nodes
+ rm -f "${ROOT}"/dev/fd[0-9]* # floppy
+ rm -f "${ROOT}"/dev/sd[a-d][a-z]* "${ROOT}"/dev/sd[e-z]* # excess sata/scsi
+ rm -f "${ROOT}"/dev/tty[a-zA-Z]* # excess tty
+ fi
+}
diff --git a/sys-apps/makedev/metadata.xml b/sys-apps/makedev/metadata.xml
new file mode 100644
index 000000000000..96a2d586367d
--- /dev/null
+++ b/sys-apps/makedev/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+</pkgmetadata>