summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2022-04-10 17:49:12 -0700
committerJason Zaman <perfinion@gentoo.org>2022-04-10 20:43:51 -0700
commit3f64fd69f40e02b19fe89b4bcdf51639763dc191 (patch)
treec53e028d87459658d6158e7651be7a85ef9a649f /sys-apps/mcstrans
parentsys-apps/secilc: update live ebuild (diff)
downloadgentoo-3f64fd69f40e02b19fe89b4bcdf51639763dc191.tar.gz
gentoo-3f64fd69f40e02b19fe89b4bcdf51639763dc191.tar.bz2
gentoo-3f64fd69f40e02b19fe89b4bcdf51639763dc191.zip
sys-apps/mcstrans: update live ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/mcstrans')
-rw-r--r--sys-apps/mcstrans/mcstrans-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/sys-apps/mcstrans/mcstrans-9999.ebuild b/sys-apps/mcstrans/mcstrans-9999.ebuild
index 631d654a0a38..75563498db4f 100644
--- a/sys-apps/mcstrans/mcstrans-9999.ebuild
+++ b/sys-apps/mcstrans/mcstrans-9999.ebuild
@@ -1,30 +1,33 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
inherit toolchain-funcs
-IUSE=""
+MY_PV="${PV//_/-}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="SELinux context translation to human readable names"
+HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
S="${WORKDIR}/${P}/${PN}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz"
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_PV}/${MY_P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
+ S="${WORKDIR}/${MY_P}"
fi
-DESCRIPTION="SELinux context translation to human readable names"
-HOMEPAGE="https://github.com/SELinuxProject/selinux/wiki"
-
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
DEPEND=">=sys-libs/libsepol-${PV}:=
>=sys-libs/libselinux-${PV}:=
- dev-libs/libpcre:=
+ dev-libs/libpcre2:=
>=sys-libs/libcap-1.10-r10:="
RDEPEND="${DEPEND}"