summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-02 23:33:41 +0000
committerSam James <sam@gentoo.org>2020-09-02 23:33:41 +0000
commit584d7f6ddc60a5e28c2be6ef94b6d8c665d20c45 (patch)
treee7af0f68e3a1ca1e20c609193bcf543fb37a302b /sys-apps/moreutils
parentapp-portage/portpeek: Stabilize 3.1.4 ALLARCHES, #740104 (diff)
downloadgentoo-584d7f6ddc60a5e28c2be6ef94b6d8c665d20c45.tar.gz
gentoo-584d7f6ddc60a5e28c2be6ef94b6d8c665d20c45.tar.bz2
gentoo-584d7f6ddc60a5e28c2be6ef94b6d8c665d20c45.zip
sys-apps/moreutils: bump to 0.64
Package-Manager: Portage-3.0.4, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/moreutils')
-rw-r--r--sys-apps/moreutils/Manifest1
-rw-r--r--sys-apps/moreutils/moreutils-0.64.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/moreutils/Manifest b/sys-apps/moreutils/Manifest
index 7fbfd8fc21d7..4f29a06c52c7 100644
--- a/sys-apps/moreutils/Manifest
+++ b/sys-apps/moreutils/Manifest
@@ -1 +1,2 @@
+DIST moreutils-0.64.tar.gz 92741 BLAKE2B 3e014a18a3b7615bcd83fd9b0a1e3010a059aae154395c2c1158f57634fe83c27503dc3aff1e116743cf80fc73ee2063ea60b03d4bece4119b962669095c71dc SHA512 94f131b9b02a8c1139dfe34abacab022687f51413c529288f57fa876676c028e200324ed855b910a7dbfb4290eb8b38b3dc182eda49988f521a550162b0a0eec
DIST moreutils_0.63.orig.tar.xz 80468 BLAKE2B 39efa522c5bf9b982b70c1180f622a7d5a489cabbeb741f2a1a0674dfe9907ef85bccccf9f9cc4ae8d3c81442b1513f0692c070b4c00f052135528dc0e47eb6f SHA512 71bd5ec4d265dff708db372189146acb067c4edaf62888755d245ccb3f4b5bb54f6c31bda68991f78c27ab231de8ea7126f947834f3604b60d7142d0357cb66b
diff --git a/sys-apps/moreutils/moreutils-0.64.ebuild b/sys-apps/moreutils/moreutils-0.64.ebuild
new file mode 100644
index 000000000000..86020a66dc68
--- /dev/null
+++ b/sys-apps/moreutils/moreutils-0.64.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="a collection of tools that nobody thought to write when Unix was young"
+HOMEPAGE="https://joeyh.name/code/moreutils/ https://git.joeyh.name/index.cgi/moreutils.git/"
+# Not available at time of release
+#SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.xz"
+SRC_URI="https://git.joeyh.name/index.cgi/moreutils.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~x86-linux"
+IUSE="+doc +perl"
+
+RDEPEND="
+ perl? (
+ dev-lang/perl
+ dev-perl/IPC-Run
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ )"
+DEPEND="
+ app-admin/eselect
+ doc? (
+ dev-lang/perl
+ >=app-text/docbook2X-0.8.8-r2
+ app-text/docbook-xml-dtd:4.4
+ )"
+
+src_prepare() {
+ # don't build manpages
+ if ! use doc ; then
+ sed -i -e '/^all:/s/$(MANS)//' -e '/man1/d' Makefile || die
+ fi
+
+ # don't install perl scripts
+ if ! use perl ; then
+ sed -i -e '/PERLSCRIPTS/d' Makefile || die
+ fi
+
+ default
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" DOCBOOKXSL=/usr/share/sgml/docbook/xsl-stylesheets PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" PREFIX="${EPREFIX}/usr" INSTALL_BIN=install install
+
+ # sys-process is more advanced than parallel from moreutils, rename it
+ if use doc; then
+ mv "${ED}"/usr/share/man/man1/{,${PN}_}parallel.1 || die
+ fi
+
+ mv "${ED}"/usr/bin/{,${PN}_}parallel || die
+}
+
+pkg_postinst() {
+ # try to make sure $EDITOR is valid for vipe (bug #604630)
+ eselect editor update
+}