summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-15 14:18:54 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-15 16:06:46 -0400
commit421bfb8a74b3b56e5c13cc0d4539bac9df51eb3a (patch)
tree237ca213ffb397c84afc65b6e60b5135d815f578 /sys-apps/noexec
parentx11-drivers/nvidia-drivers: use the new systemd_get_sleepdir (diff)
downloadgentoo-421bfb8a74b3b56e5c13cc0d4539bac9df51eb3a.tar.gz
gentoo-421bfb8a74b3b56e5c13cc0d4539bac9df51eb3a.tar.bz2
gentoo-421bfb8a74b3b56e5c13cc0d4539bac9df51eb3a.zip
sys-apps/noexec: EAPI6->8, fix runtime, run eautoreconf for clang16
wrt runtime, lacked $(get_libdir): ld.so: object '/usr/lib/libnoexec.so' from LD_PRELOAD cannot be preloaded (no bug, assume nobody actually use this) Don't think the glibc dependency makes sense, but given LD_PRELOAD tricks I would rather leave alone without inspecting and trying musl. Also GPL-2 -> GPL-2+, put glibc in RDEPEND too fwiw, and remove .la. Closes: https://bugs.gentoo.org/851816 Closes: https://bugs.gentoo.org/874426 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'sys-apps/noexec')
-rw-r--r--sys-apps/noexec/noexec-1.1.0-r1.ebuild14
-rw-r--r--sys-apps/noexec/noexec-1.1.0-r2.ebuild32
2 files changed, 32 insertions, 14 deletions
diff --git a/sys-apps/noexec/noexec-1.1.0-r1.ebuild b/sys-apps/noexec/noexec-1.1.0-r1.ebuild
deleted file mode 100644
index 5e25d33d7981..000000000000
--- a/sys-apps/noexec/noexec-1.1.0-r1.ebuild
+++ /dev/null
@@ -1,14 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="a package for preventing processes from using exec system calls"
-HOMEPAGE="http://noexec.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-
-DEPEND="sys-libs/glibc"
diff --git a/sys-apps/noexec/noexec-1.1.0-r2.ebuild b/sys-apps/noexec/noexec-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..ab5153da8055
--- /dev/null
+++ b/sys-apps/noexec/noexec-1.1.0-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Package for preventing processes from using exec system calls"
+HOMEPAGE="https://noexec.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="sys-libs/glibc"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -e "/^#define PRELOAD_LIBRARY_PATH/s|/usr/lib|${EPREFIX}/usr/$(get_libdir)|" \
+ -i src/noexec_macro.h || die
+
+ eautoreconf #874426
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}