summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-06-17 21:35:00 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-06-17 22:17:52 +0200
commit6894be47c81af6554e6f224b115798c33a12cea9 (patch)
treedb4ce55a13704a16b195b588b56c5ab9469f733d /sys-apps/openrazer
parentdev-util/radare2: add 5.8.8 (diff)
downloadgentoo-6894be47c81af6554e6f224b115798c33a12cea9.tar.gz
gentoo-6894be47c81af6554e6f224b115798c33a12cea9.tar.bz2
gentoo-6894be47c81af6554e6f224b115798c33a12cea9.zip
sys-apps/openrazer: drop old 3.5.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps/openrazer')
-rw-r--r--sys-apps/openrazer/Manifest1
-rw-r--r--sys-apps/openrazer/openrazer-3.5.1.ebuild160
2 files changed, 0 insertions, 161 deletions
diff --git a/sys-apps/openrazer/Manifest b/sys-apps/openrazer/Manifest
index aa986006bcaa..bbd4765ef075 100644
--- a/sys-apps/openrazer/Manifest
+++ b/sys-apps/openrazer/Manifest
@@ -1,3 +1,2 @@
-DIST openrazer-3.5.1.tar.gz 240254 BLAKE2B 7f6b887c22c81c8cd3d7908f94748879aa4c89f6446e073aeaed0d33f8d58bd7b618768a9915a451d6659c0cdf428b52e055641420553a00f2cf41b0a9737487 SHA512 dc32f040f4b9ecbefbd2b4afc34edcc97fbda16f6dd9a64ed61d637233ea5d0e6f046685837635a177d3cab8506224c973ea26972a6ea7cc20d7bcce60065e39
DIST openrazer-3.6.0.tar.gz 243924 BLAKE2B 7b782990cf5afedb88adafe310bcba6512ff8009cee6bbf8e005f4780c711ccc724cacc3056f471002268c61e6d3bfce0ba6b5c72e502ad83b954c45f70b521a SHA512 fb08a8a38ce582099e6c1a98df73aacf9dd437beb4be9cc0e7e3e14f4da6e53de90058a8cc22daeda0bbcfe111b2bc5a38c0503e0020239d44dae2f199219695
DIST openrazer-3.6.1.tar.gz 244061 BLAKE2B f5fa8bf4ec383cf92d3c9c66db6b2f6cc9e4cf1969558d187ff62e687316b861d3c0f0ba37f5addc0911a49794acc648ae2d6be6f519ea1d33afa3cc9ab7bd1b SHA512 1e1db191e4daa028fe177e9c50ddf2dfffdf7c8ba68d108a2e74232b9accb344dbc5c3352aba223434cf16d79c113e7ba19dc9f2e6672758153c25ba9391cbff
diff --git a/sys-apps/openrazer/openrazer-3.5.1.ebuild b/sys-apps/openrazer/openrazer-3.5.1.ebuild
deleted file mode 100644
index 1c4a836bb8ba..000000000000
--- a/sys-apps/openrazer/openrazer-3.5.1.ebuild
+++ /dev/null
@@ -1,160 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit readme.gentoo-r1 systemd udev xdg-utils distutils-r1 linux-mod
-
-DESCRIPTION="Drivers and user-space daemon to control Razer devices on GNU/Linux"
-HOMEPAGE="https://openrazer.github.io/
- https://github.com/openrazer/openrazer/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-
-IUSE="+client +daemon"
-REQUIRED_USE="
- client? ( daemon )
- daemon? ( ${PYTHON_REQUIRED_USE} )
- test? ( daemon )
-"
-
-RDEPEND="
- client? ( dev-python/numpy[${PYTHON_USEDEP}] )
- daemon? (
- acct-group/plugdev
- dev-python/daemonize[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/notify2[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
- x11-misc/xautomation
- x11-misc/xdotool
- )
-"
-BDEPEND="
- ${RDEPEND}
- virtual/linux-sources
-"
-
-DOCS=( README.md )
-
-DOC_CONTENTS="To successfully use OpenRazer: load desired kernel module
-(razeraccessory, razerkbd, razerkraken and/or razermouse),
-add your user to the \"plugdev\" group and start the OpenRazer daemon.
-To automatically start up the OpenRazer daemon on session login copy
-/usr/share/openrazer/openrazer-daemon.desktop file into Your user's
-~/.config/autostart/ directory."
-
-BUILD_TARGETS="clean driver"
-BUILD_PARAMS="-C ${S} SUBDIRS=${S}/driver KERNELDIR=${KERNEL_DIR}"
-MODULE_NAMES="
- razeraccessory(hid:${S}/driver)
- razerkbd(hid:${S}/driver)
- razerkraken(hid:${S}/driver)
- razermouse(hid:${S}/driver)
-"
-
-distutils_enable_tests unittest
-
-python_compile() {
- if use daemon ; then
- ( cd "${S}"/daemon || die ; distutils-r1_python_compile )
- fi
- if use client ; then
- ( cd "${S}"/pylib || die ; distutils-r1_python_compile )
- fi
-}
-
-python_install() {
- if use daemon ; then
- ( cd "${S}"/daemon || die ; distutils-r1_python_install )
- python_scriptinto /usr/bin
- python_newscript "${S}"/daemon/run_openrazer_daemon.py ${PN}-daemon
- fi
- if use client ; then
- ( cd "${S}"/pylib || die ; distutils-r1_python_install )
- fi
-}
-
-src_prepare() {
- xdg_environment_reset
- distutils-r1_src_prepare
-
- # Remove bad tests.
- rm "${S}"/daemon/tests/test_effect_sync.py || die
-}
-
-src_compile() {
- linux-mod_src_compile
- distutils-r1_src_compile
-
- if use daemon ; then
- emake -C "${S}"/daemon PREFIX=/usr service
- fi
-
- readme.gentoo_create_doc
-}
-
-src_test() {
- ( cd "${S}"/daemon/tests || die ; distutils-r1_src_test )
-}
-
-src_install() {
- linux-mod_src_install
- distutils-r1_src_install
-
- udev_dorules "${S}"/install_files/udev/99-razer.rules
- exeinto "$(get_udevdir)"
- doexe "${S}"/install_files/udev/razer_mount
-
- # Install configuration example so that the daemon does not complain.
- insinto /usr/share/${PN}
- newins "${S}"/daemon/resources/razer.conf razer.conf.example
-
- if use daemon ; then
- # dbus service
- insinto /usr/share/dbus-1/services
- doins "${S}"/daemon/org.razer.service
-
- # systemd unit
- systemd_douserunit "${S}"/daemon/${PN}-daemon.service
-
- # xdg autostart example file
- insinto /usr/share/${PN}
- doins "${S}"/install_files/desktop/openrazer-daemon.desktop
-
- # Manpages
- doman "${S}"/daemon/resources/man/${PN}-daemon.8
- doman "${S}"/daemon/resources/man/razer.conf.5
- fi
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- udev_reload
-
- if use daemon ; then
- xdg_icon_cache_update
- xdg_desktop_database_update
- fi
-
- readme.gentoo_print_elog
-}
-
-pkg_postrm() {
- linux-mod_pkg_postrm
- udev_reload
-
- if use daemon ; then
- xdg_icon_cache_update
- xdg_desktop_database_update
- fi
-}