summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-12-16 19:50:09 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-12-16 22:44:58 +0100
commitf44394e09751ab1aca75eae5f2c7076705dadc93 (patch)
tree07ccd186319dc84c3abe66d74d1652ddc1455f0c /sys-apps/openrazer
parentsci-electronics/nvc: drop old 1.10.4 (diff)
downloadgentoo-f44394e09751ab1aca75eae5f2c7076705dadc93.tar.gz
gentoo-f44394e09751ab1aca75eae5f2c7076705dadc93.tar.bz2
gentoo-f44394e09751ab1aca75eae5f2c7076705dadc93.zip
sys-apps/openrazer: drop old 3.6.1-r2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps/openrazer')
-rw-r--r--sys-apps/openrazer/Manifest1
-rw-r--r--sys-apps/openrazer/openrazer-3.6.1-r2.ebuild173
2 files changed, 0 insertions, 174 deletions
diff --git a/sys-apps/openrazer/Manifest b/sys-apps/openrazer/Manifest
index 871aeb6113e9..313a88ad4c65 100644
--- a/sys-apps/openrazer/Manifest
+++ b/sys-apps/openrazer/Manifest
@@ -1,2 +1 @@
-DIST openrazer-3.6.1.tar.gz 244061 BLAKE2B f5fa8bf4ec383cf92d3c9c66db6b2f6cc9e4cf1969558d187ff62e687316b861d3c0f0ba37f5addc0911a49794acc648ae2d6be6f519ea1d33afa3cc9ab7bd1b SHA512 1e1db191e4daa028fe177e9c50ddf2dfffdf7c8ba68d108a2e74232b9accb344dbc5c3352aba223434cf16d79c113e7ba19dc9f2e6672758153c25ba9391cbff
DIST openrazer-3.7.0.tar.gz 249201 BLAKE2B fd3d98b1d3c46623392a5cd42c8cafd605a7e2a6ec3d42f1f8f3c27b20fe06a149d55c45615a574957a14b66d20371cc9ddfd551c44659bd3887e53a3ad44570 SHA512 5067510fc22040f7a351556499db85a728863d97b56cdb26ea15adebe062403d2a4927c9bdcd620bddeb3388f1db184c0036dd121495b27ddb0d8d80cc17aafb
diff --git a/sys-apps/openrazer/openrazer-3.6.1-r2.ebuild b/sys-apps/openrazer/openrazer-3.6.1-r2.ebuild
deleted file mode 100644
index d8b3f16dadcc..000000000000
--- a/sys-apps/openrazer/openrazer-3.6.1-r2.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit readme.gentoo-r1 systemd udev xdg-utils distutils-r1 linux-mod-r1
-
-DESCRIPTION="Drivers and user-space daemon to control Razer devices on GNU/Linux"
-HOMEPAGE="https://openrazer.github.io/
- https://github.com/openrazer/openrazer/"
-
-if [[ ${PV} == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
- KEYWORDS="amd64 ~x86"
-fi
-
-LICENSE="GPL-2+"
-SLOT="0"
-
-IUSE="+client +daemon"
-REQUIRED_USE="
- client? ( daemon )
- daemon? ( ${PYTHON_REQUIRED_USE} )
- test? ( daemon )
-"
-
-RDEPEND="
- client? ( dev-python/numpy[${PYTHON_USEDEP}] )
- daemon? (
- acct-group/plugdev
- dev-python/daemonize[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/notify2[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
- dev-python/pyudev[${PYTHON_USEDEP}]
- dev-python/setproctitle[${PYTHON_USEDEP}]
- x11-libs/gtk+:3[introspection]
- x11-misc/xautomation
- x11-misc/xdotool
- )
-"
-BDEPEND="
- ${RDEPEND}
- virtual/linux-sources
-"
-
-DOCS=( README.md )
-
-DOC_CONTENTS="To successfully use OpenRazer: load desired kernel module
-(razeraccessory, razerkbd, razerkraken and/or razermouse),
-add your user to the \"plugdev\" group and start the OpenRazer daemon.
-To automatically start up the OpenRazer daemon on session login copy
-/usr/share/openrazer/openrazer-daemon.desktop file into Your user's
-~/.config/autostart/ directory."
-
-distutils_enable_tests unittest
-
-python_compile() {
- cd "${S}"/daemon || die
-
- distutils_pep517_install "${BUILD_DIR}"/install
-
- if use client ; then
- cd "${S}"/pylib || die
-
- distutils_pep517_install "${BUILD_DIR}"/install
- fi
-}
-
-python_install() {
- distutils-r1_python_install
-
- python_scriptinto /usr/bin
- python_newscript "${S}"/daemon/run_openrazer_daemon.py ${PN}-daemon
-}
-
-src_prepare() {
- xdg_environment_reset
-
- if use daemon ; then
- distutils-r1_src_prepare
- else
- default
- fi
-
- # Remove bad tests.
- rm "${S}"/daemon/tests/test_effect_sync.py || die
-}
-
-src_compile() {
- local -a modargs=(
- SUBDIRS="${S}"/driver
- KERNELDIR="${KERNEL_DIR}"
- )
- local -a modlist=(
- {razeraccessory,razerkbd,razerkraken,razermouse}="hid:${S}:driver"
- )
- linux-mod-r1_src_compile
-
- if use daemon ; then
- distutils-r1_src_compile
-
- emake -C "${S}"/daemon PREFIX=/usr service
- fi
-
- readme.gentoo_create_doc
-}
-
-src_test() {
- cd "${S}"/daemon/tests || die
-
- distutils-r1_src_test
-}
-
-src_install() {
- linux-mod-r1_src_install
-
- udev_dorules "${S}"/install_files/udev/99-razer.rules
- exeinto "$(get_udevdir)"
- doexe "${S}"/install_files/udev/razer_mount
-
- # Install configuration example so that the daemon does not complain.
- insinto /usr/share/${PN}
- newins "${S}"/daemon/resources/razer.conf razer.conf.example
-
- if use daemon ; then
- # Python libraries/scripts, "client" also requires USE="daemon"
- distutils-r1_src_install
-
- # dbus service
- insinto /usr/share/dbus-1/services
- doins "${S}"/daemon/org.razer.service
-
- # systemd unit
- systemd_douserunit "${S}"/daemon/${PN}-daemon.service
-
- # xdg autostart example file
- insinto /usr/share/${PN}
- doins "${S}"/install_files/desktop/openrazer-daemon.desktop
-
- # Manpages
- doman "${S}"/daemon/resources/man/${PN}-daemon.8
- doman "${S}"/daemon/resources/man/razer.conf.5
- fi
-}
-
-pkg_postinst() {
- linux-mod-r1_pkg_postinst
- udev_reload
-
- if use daemon ; then
- xdg_icon_cache_update
- xdg_desktop_database_update
- fi
-
- readme.gentoo_print_elog
-}
-
-pkg_postrm() {
- udev_reload
-
- if use daemon ; then
- xdg_icon_cache_update
- xdg_desktop_database_update
- fi
-}