summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-23 09:06:55 +0000
committerSam James <sam@gentoo.org>2023-03-23 09:06:55 +0000
commit68395d1f96ed3dfd76069bdec4bc767b72b42191 (patch)
tree3fbfd0eefdf07ffd711c6a2ea0e1bfd5d6729bce /sys-apps/pcsc-tools
parentnet-libs/ntirpc: add 4.3 (diff)
downloadgentoo-68395d1f96ed3dfd76069bdec4bc767b72b42191.tar.gz
gentoo-68395d1f96ed3dfd76069bdec4bc767b72b42191.tar.bz2
gentoo-68395d1f96ed3dfd76069bdec4bc767b72b42191.zip
sys-apps/pcsc-tools: add 1.6.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 5468c7cb8baf..5a1a1ae0f011 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,2 +1,3 @@
DIST pcsc-tools-1.6.0.tar.bz2 304960 BLAKE2B a60d280d39689d7eaa407aa5857c63af0acda3791e5d9f5c2f62048260178dc728fb179aed3c369340e192ba9b3d5db04bacbe5cc6ef1519c7cde55e10ca6b45 SHA512 951014510dcfd011fc08c92a927ed8a39751c15cd9278e9bd61693a2743a82d4b88907e01e013738f6b5afb569cb4d9e9802ee575c731b83da33e92f96eb5d50
DIST pcsc-tools-1.6.1.tar.bz2 313105 BLAKE2B 62169f4bab81cfe137098b863ae572df283498f7fcb6b6ecaef9122ccc530d6201805b13903826887c70363443d02e43d0d0fb88e15d5f634fc0e1e775c3ecaf SHA512 fc1a6bdea55ee1194d08998f229870b7fb65f53b3b5ddb209540980d95dab8dfb62d4bc865716d0120bb843d5095b0ad9286c42ad352e52c1cfe48ef28b5adaf
+DIST pcsc-tools-1.6.2.tar.bz2 320182 BLAKE2B 88a76f4120a183df909ce9d189e38e51897080839ebe7ca85aa4447a441363e6917ddb1c5e6c0e881c8792078700676ad1cfe24609957a4fef54374d5be824a4 SHA512 20104baefa7928a86d21cee49d045cc35b8e74fec5be79ba5608ae046a110096efae96768d281e0f1350f71a889f89c675336d8264c75f8423369a49c03b42a8
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.2.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.2.ebuild
new file mode 100644
index 000000000000..4effc00f4cbf
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="https://pcsc-tools.apdu.fr/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="https://pcsc-tools.apdu.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}