summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-09-03 12:58:59 +0200
committerDavid Seifert <soap@gentoo.org>2022-09-03 12:58:59 +0200
commit90889c58eeaf4585f8fd0482113227144c42e6d8 (patch)
tree5281d722a42a1ad6fc6c825d817efaf8548b57b4 /sys-apps/pcsc-tools
parentdev-python/openapi-spec-validator: Fix dependencies (diff)
downloadgentoo-90889c58eeaf4585f8fd0482113227144c42e6d8.tar.gz
gentoo-90889c58eeaf4585f8fd0482113227144c42e6d8.tar.bz2
gentoo-90889c58eeaf4585f8fd0482113227144c42e6d8.zip
sys-apps/pcsc-tools: drop 1.5.6, 1.5.7
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild62
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild62
3 files changed, 0 insertions, 125 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 6299f8f4b920..6fadd922a9c8 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,2 +1 @@
-DIST pcsc-tools-1.5.6.tar.bz2 289691 BLAKE2B 35dd50a3a8babff89f9e5d769ef70a573e58b2780d680c82dfa07177a3daaf527b5ccca665c901f9667ca4a81719916bd5aebb2e9b1b4d0301001498fe587832 SHA512 94076ed5af698afcec05da9645d7108c02c110fd0ee5efecbd8e0c7eb5ed9a55ee857d23b79ab2ccb93847f8a36f996fa9d521d999395f63274d4bf1d9cf3d26
DIST pcsc-tools-1.5.7.tar.bz2 292637 BLAKE2B f0bfa9f680a2f2b348d2baef4b4b4567008163f47d7d7e6cec694cdc424626c5c6f18c475f0e8d4c5cd49111315b3c8a934fecf30afe90bbebc0a15f8d6f4a1d SHA512 58d70f41c5815297def7d8b64807e960db85719996771ecb43a4320d3f3fc82e2deb133d9ca97b3a4e8e76267294b3339d8883ba4770bdd0071566e1ce457501
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild
deleted file mode 100644
index 951db2412435..000000000000
--- a/sys-apps/pcsc-tools/pcsc-tools-1.5.6.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop toolchain-funcs xdg-utils
-
-DESCRIPTION="PC/SC Architecture smartcard tools"
-HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
-SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 x86"
-IUSE="gtk network-cron"
-
-DEPEND=">=sys-apps/pcsc-lite-1.4.14"
-RDEPEND="${DEPEND}
- dev-perl/pcsc-perl
- gtk? ( dev-perl/Gtk2 )"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=(
- README Changelog
-)
-
-src_compile() {
- # explicitly only build the pcsc_scan application, or the man
- # pages will be gzipped first, and then unpacked.
- emake pcsc_scan CC="$(tc-getCC)"
-}
-
-src_install() {
- einstalldocs
-
- # install manually, makes it much easier since the Makefile
- # requires fiddling with
- dobin ATR_analysis scriptor pcsc_scan
- doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
-
- if use gtk; then
- domenu gscriptor.desktop
- dobin gscriptor
- doman gscriptor.1p
- fi
-
- if use network-cron ; then
- exeinto /etc/cron.monthly
- newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
- fi
-
- insinto /usr/share/pcsc
- doins smartcard_list.txt
-}
-
-pkg_postinst() {
- use gtk && xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild
deleted file mode 100644
index 18bbcf455751..000000000000
--- a/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit desktop toolchain-funcs xdg-utils
-
-DESCRIPTION="PC/SC Architecture smartcard tools"
-HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
-SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
-IUSE="gtk network-cron"
-
-DEPEND=">=sys-apps/pcsc-lite-1.4.14"
-RDEPEND="${DEPEND}
- dev-perl/pcsc-perl
- gtk? ( dev-perl/Gtk2 )"
-BDEPEND="virtual/pkgconfig"
-
-DOCS=(
- README Changelog
-)
-
-src_compile() {
- # explicitly only build the pcsc_scan application, or the man
- # pages will be gzipped first, and then unpacked.
- emake pcsc_scan CC="$(tc-getCC)"
-}
-
-src_install() {
- einstalldocs
-
- # install manually, makes it much easier since the Makefile
- # requires fiddling with
- dobin ATR_analysis scriptor pcsc_scan
- doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
-
- if use gtk; then
- domenu gscriptor.desktop
- dobin gscriptor
- doman gscriptor.1p
- fi
-
- if use network-cron ; then
- exeinto /etc/cron.monthly
- newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
- fi
-
- insinto /usr/share/pcsc
- doins smartcard_list.txt
-}
-
-pkg_postinst() {
- use gtk && xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
-}