summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-01 00:01:26 +0000
committerSam James <sam@gentoo.org>2023-01-01 00:04:22 +0000
commitb890870106d06f6ea63fcda608bae0fa43c49bea (patch)
treec82c6d657d2a7b07189088ceb60d3408b6cc3f20 /sys-apps/pcsc-tools
parentapp-crypt/sbctl: add 0.10 (diff)
downloadgentoo-b890870106d06f6ea63fcda608bae0fa43c49bea.tar.gz
gentoo-b890870106d06f6ea63fcda608bae0fa43c49bea.tar.bz2
gentoo-b890870106d06f6ea63fcda608bae0fa43c49bea.zip
sys-apps/pcsc-tools: add 1.6.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 0a6334fb6941..5468c7cb8baf 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1 +1,2 @@
DIST pcsc-tools-1.6.0.tar.bz2 304960 BLAKE2B a60d280d39689d7eaa407aa5857c63af0acda3791e5d9f5c2f62048260178dc728fb179aed3c369340e192ba9b3d5db04bacbe5cc6ef1519c7cde55e10ca6b45 SHA512 951014510dcfd011fc08c92a927ed8a39751c15cd9278e9bd61693a2743a82d4b88907e01e013738f6b5afb569cb4d9e9802ee575c731b83da33e92f96eb5d50
+DIST pcsc-tools-1.6.1.tar.bz2 313105 BLAKE2B 62169f4bab81cfe137098b863ae572df283498f7fcb6b6ecaef9122ccc530d6201805b13903826887c70363443d02e43d0d0fb88e15d5f634fc0e1e775c3ecaf SHA512 fc1a6bdea55ee1194d08998f229870b7fb65f53b3b5ddb209540980d95dab8dfb62d4bc865716d0120bb843d5095b0ad9286c42ad352e52c1cfe48ef28b5adaf
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild
new file mode 100644
index 000000000000..5d0778848964
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.6.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}