summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Davies <jpds@protonmail.com>2021-03-18 00:59:37 +0000
committerJason Zaman <perfinion@gentoo.org>2021-04-02 21:15:25 -0700
commitf4a7c818157ee4058420732c796a225b1deafda0 (patch)
treefc608d863d0598bf88c42b5e6fc5a8f3eb9964f3 /sys-apps/policycoreutils
parentsys-apps/policycoreutils: Version updated to 3.2. (diff)
downloadgentoo-f4a7c818157ee4058420732c796a225b1deafda0.tar.gz
gentoo-f4a7c818157ee4058420732c796a225b1deafda0.tar.bz2
gentoo-f4a7c818157ee4058420732c796a225b1deafda0.zip
sys-apps/policycoreutils: Sync live ebuild.
Signed-off-by: Jonathan Davies <jpds@protonmail.com> Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'sys-apps/policycoreutils')
-rw-r--r--sys-apps/policycoreutils/policycoreutils-9999.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/sys-apps/policycoreutils/policycoreutils-9999.ebuild b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
index 44e8c3b34eb6..fcc4708f1b9b 100644
--- a/sys-apps/policycoreutils/policycoreutils-9999.ebuild
+++ b/sys-apps/policycoreutils/policycoreutils-9999.ebuild
@@ -1,19 +1,13 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+EAPI="7"
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
PYTHON_REQ_USE="xml"
inherit multilib python-r1 toolchain-funcs bash-completion-r1
-MY_P="${P//_/-}"
-
-MY_RELEASEDATE="20200710"
EXTRAS_VER="1.37"
-SEMNG_VER="${PV}"
-SELNX_VER="${PV}"
-SEPOL_VER="${PV}"
IUSE="audit pam split-usr"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -25,14 +19,14 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
SRC_URI="https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
- S1="${WORKDIR}/${MY_P}/${PN}"
+ S1="${WORKDIR}/${PN}"
S2="${WORKDIR}/policycoreutils-extra"
S="${S1}"
else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz
+ SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${PV}/${P}.tar.gz
https://dev.gentoo.org/~perfinion/distfiles/policycoreutils-extra-${EXTRAS_VER}.tar.bz2"
KEYWORDS="~amd64 ~arm64 ~mips ~x86"
- S1="${WORKDIR}/${MY_P}"
+ S1="${WORKDIR}/${P}"
S2="${WORKDIR}/policycoreutils-extra"
S="${S1}"
fi
@@ -40,9 +34,9 @@ fi
LICENSE="GPL-2"
SLOT="0"
-DEPEND=">=sys-libs/libselinux-${SELNX_VER}:=[python,${PYTHON_USEDEP}]
- >=sys-libs/libsemanage-${SEMNG_VER}:=[python(+),${PYTHON_USEDEP}]
- >=sys-libs/libsepol-${SEPOL_VER}:=
+DEPEND=">=sys-libs/libselinux-${PV}:=[python,${PYTHON_USEDEP}]
+ >=sys-libs/libsemanage-${PV}:=[python(+),${PYTHON_USEDEP}]
+ >=sys-libs/libsepol-${PV}:=
sys-libs/libcap-ng:=
>=app-admin/setools-4.2.0[${PYTHON_USEDEP}]
audit? ( >=sys-process/audit-1.5.1[python,${PYTHON_USEDEP}] )