summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-08 16:37:32 -0500
committerSam James <sam@gentoo.org>2024-01-09 00:06:18 +0000
commite48cfb03c694ce1dac06d7711dac4e9e4e321f12 (patch)
tree587984c47d2aa9e4b46e91c4a32caaeb433eb32b /sys-apps/portage
parenttoolchain.eclass: go back to flex (diff)
downloadgentoo-e48cfb03c694ce1dac06d7711dac4e9e4e321f12.tar.gz
gentoo-e48cfb03c694ce1dac06d7711dac4e9e4e321f12.tar.bz2
gentoo-e48cfb03c694ce1dac06d7711dac4e9e4e321f12.zip
sys-apps/portage: fix invalid python bytecompile stage
python software needs to have two postprocessing passes run: - fix up shebangs of bin scripts - optimize importable libraries in sitedir For some reason, both directories get both passes applied, which doesn't actually do anything useful. Worse, the shebang fixing happens *after* the optimizing, which means that if any shebang fixing occurs in the sitedir, it invalidates the bytecode. Fixes: be37f979f5f838c8a4039aaba379a3e373af0b6f Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/portage')
-rw-r--r--sys-apps/portage/portage-3.0.57-r1.ebuild (renamed from sys-apps/portage/portage-3.0.57.ebuild)4
-rw-r--r--sys-apps/portage/portage-3.0.59-r1.ebuild (renamed from sys-apps/portage/portage-3.0.59.ebuild)4
-rw-r--r--sys-apps/portage/portage-3.0.60-r1.ebuild (renamed from sys-apps/portage/portage-3.0.60.ebuild)2
-rw-r--r--sys-apps/portage/portage-9999.ebuild4
4 files changed, 7 insertions, 7 deletions
diff --git a/sys-apps/portage/portage-3.0.57.ebuild b/sys-apps/portage/portage-3.0.57-r1.ebuild
index f52331d84170..57f781d85350 100644
--- a/sys-apps/portage/portage-3.0.57.ebuild
+++ b/sys-apps/portage/portage-3.0.57-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -187,8 +187,8 @@ my_src_install() {
)
meson_src_install
- python_optimize "${pydirs[@]}"
python_fix_shebang "${pydirs[@]}"
+ python_optimize "${pydirs[@]}"
}
pkg_preinst() {
diff --git a/sys-apps/portage/portage-3.0.59.ebuild b/sys-apps/portage/portage-3.0.59-r1.ebuild
index 1ff0ccb90547..2dd0b1031597 100644
--- a/sys-apps/portage/portage-3.0.59.ebuild
+++ b/sys-apps/portage/portage-3.0.59-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -185,8 +185,8 @@ my_src_install() {
)
meson_src_install
- python_optimize "${pydirs[@]}"
python_fix_shebang "${pydirs[@]}"
+ python_optimize "${pydirs[@]}"
}
pkg_preinst() {
diff --git a/sys-apps/portage/portage-3.0.60.ebuild b/sys-apps/portage/portage-3.0.60-r1.ebuild
index 7d462427195c..36c0d5fdf384 100644
--- a/sys-apps/portage/portage-3.0.60.ebuild
+++ b/sys-apps/portage/portage-3.0.60-r1.ebuild
@@ -185,8 +185,8 @@ my_src_install() {
)
meson_src_install
- python_optimize "${pydirs[@]}"
python_fix_shebang "${pydirs[@]}"
+ python_optimize "${pydirs[@]}"
}
pkg_preinst() {
diff --git a/sys-apps/portage/portage-9999.ebuild b/sys-apps/portage/portage-9999.ebuild
index 0fa6790375b9..36c0d5fdf384 100644
--- a/sys-apps/portage/portage-9999.ebuild
+++ b/sys-apps/portage/portage-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -185,8 +185,8 @@ my_src_install() {
)
meson_src_install
- python_optimize "${pydirs[@]}"
python_fix_shebang "${pydirs[@]}"
+ python_optimize "${pydirs[@]}"
}
pkg_preinst() {