summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/powerpc-utils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/powerpc-utils')
-rw-r--r--sys-apps/powerpc-utils/Manifest3
-rw-r--r--sys-apps/powerpc-utils/metadata.xml5
-rw-r--r--sys-apps/powerpc-utils/powerpc-utils-1.1.3.18-r2.ebuild53
3 files changed, 61 insertions, 0 deletions
diff --git a/sys-apps/powerpc-utils/Manifest b/sys-apps/powerpc-utils/Manifest
new file mode 100644
index 000000000000..ade3fe0e3c48
--- /dev/null
+++ b/sys-apps/powerpc-utils/Manifest
@@ -0,0 +1,3 @@
+DIST powerpc-utils-cleanup.patch.bz2 7255 RMD160 361b792b9770d369e4a88941594f679967ea0fdc SHA1 b9443bc46999d2953409665dc1b24fa2978db7ee SHA256 05592c22230afdef79c92556c2161262ec32cee3feaf29e666bf29ba0ef9b39f
+DIST powerpc-utils_1.1.3-18.diff.gz 27252 RMD160 ec806ada35999fafed571606c9b676f74c9f7040 SHA1 bdff200bc9280b17aa3a8cde52d9784eb7b4fb89 SHA256 7cb699d5e647fe39a9cc1a0276a9e9dc381061a8ecba13671ce8bc1f1037edf4
+DIST powerpc-utils_1.1.3.orig.tar.gz 25104 RMD160 86eacaf0a7f022a850b6540b09220dacb49d0949 SHA1 049baa3dcb879a89afc4da0ee0b90d279bad3b24 SHA256 fde422d13e75d0154fa5d9d94ba3c74f4a91dc0f8ba0351e675ee99eeaddbe95
diff --git a/sys-apps/powerpc-utils/metadata.xml b/sys-apps/powerpc-utils/metadata.xml
new file mode 100644
index 000000000000..034c09eb248a
--- /dev/null
+++ b/sys-apps/powerpc-utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ppc</herd>
+</pkgmetadata>
diff --git a/sys-apps/powerpc-utils/powerpc-utils-1.1.3.18-r2.ebuild b/sys-apps/powerpc-utils/powerpc-utils-1.1.3.18-r2.ebuild
new file mode 100644
index 000000000000..af5af52adfbd
--- /dev/null
+++ b/sys-apps/powerpc-utils/powerpc-utils-1.1.3.18-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils versionator toolchain-funcs
+
+BASEVER=$(get_version_component_range 1-3)
+DEBREV=$(get_version_component_range 4)
+
+DESCRIPTION="PowerPC utilities including nvsetenv, and additional OldWorld apps"
+SRC_URI="http://http.us.debian.org/debian/pool/main/p/powerpc-utils/${PN}_${BASEVER}.orig.tar.gz
+ http://http.us.debian.org/debian/pool/main/p/powerpc-utils/${PN}_${BASEVER}-${DEBREV}.diff.gz
+ mirror://gentoo/${PN}-cleanup.patch.bz2"
+
+HOMEPAGE="http://http.us.debian.org/debian/pool/main/p/powerpc-utils/"
+KEYWORDS="-* ppc ppc64"
+IUSE=""
+DEPEND=""
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="GPL-2"
+
+S="${WORKDIR}/pmac-utils"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${BASEVER}-${DEBREV}.diff
+ epatch "${WORKDIR}"/${PN}-cleanup.patch
+
+ # use users CFLAGS, LDFLAGS and CC, bug 280400
+ sed -i -e "/LDFLAGS =/d" -e "/CC\t=/d" -e "s/CFLAGS\t=/CFLAGS +=/" \
+ -e "s/-g -O2/-Wstrict-prototypes/" Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dosbin autoboot backlight bootsched clock fblevel fdeject fnset \
+ || die "dosbin failed"
+ dosbin macos mousemode nvsetenv nvsetvol nvvideo sndvolmix trackpad \
+ || die "dosbin failed"
+ doman autoboot.8 bootsched.8 clock.8 fblevel.8 fdeject.8 macos.8 \
+ || die "doman failed"
+ doman mousemode.8 nvsetenv.8 nvsetvol.8 nvvideo.8 sndvolmix.8 trackpad.8 \
+ || die "doman failed"
+
+ ewarn "The lsprop utility has been moved into the ibm-powerpc-utils package."
+}