summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2020-05-18 18:36:47 +0300
committerSergey Popov <pinkbyte@gentoo.org>2020-05-18 18:37:36 +0300
commitc1efc6447da5d488943b7ac531d8b1709dceffe5 (patch)
tree2192112c032e831b23c4df31cdf4fa47bf6de55f /sys-apps/proot
parentdev-python/hcloud-python: add test dep (diff)
downloadgentoo-c1efc6447da5d488943b7ac531d8b1709dceffe5.tar.gz
gentoo-c1efc6447da5d488943b7ac531d8b1709dceffe5.tar.bz2
gentoo-c1efc6447da5d488943b7ac531d8b1709dceffe5.zip
sys-apps/proot-5.1.0-r2: remove support for static and live builds
They are effectively not working since the introduction Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Sergey Popov <pinkbyte@gentoo.org>
Diffstat (limited to 'sys-apps/proot')
-rw-r--r--sys-apps/proot/proot-5.1.0-r2.ebuild18
1 files changed, 4 insertions, 14 deletions
diff --git a/sys-apps/proot/proot-5.1.0-r2.ebuild b/sys-apps/proot/proot-5.1.0-r2.ebuild
index ac2eea07dbf7..32cc49074395 100644
--- a/sys-apps/proot/proot-5.1.0-r2.ebuild
+++ b/sys-apps/proot/proot-5.1.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,20 +6,15 @@ MY_PN="PRoot"
inherit eutils toolchain-funcs
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/proot-me/${MY_PN}.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
+SRC_URI="https://github.com/proot-me/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
DESCRIPTION="User-space implementation of chroot, mount --bind, and binfmt_misc"
HOMEPAGE="https://proot-me.github.io"
LICENSE="GPL-2"
SLOT="0"
-IUSE="care static test"
+IUSE="care test"
RDEPEND="care? ( app-arch/libarchive:0= )
sys-libs/talloc"
@@ -38,11 +33,6 @@ PATCHES=(
"${FILESDIR}/${PN}-5.1.0-loader.patch"
)
-src_prepare() {
- default
- use static && append-ldflags -static
-}
-
src_compile() {
# build the proot and care targets
emake -C src V=1 \