summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2023-07-01 20:00:18 -0400
committerMike Gilbert <floppym@gentoo.org>2023-07-01 20:00:18 -0400
commit991e6dec5884cefb526e3949ee8cd152ca487e75 (patch)
tree547fc3b393d3d6cb1001cbcd49766731f2711805 /sys-apps/sandbox
parentapp-misc/ddccontrol-db: bump (diff)
downloadgentoo-991e6dec5884cefb526e3949ee8cd152ca487e75.tar.gz
gentoo-991e6dec5884cefb526e3949ee8cd152ca487e75.tar.bz2
gentoo-991e6dec5884cefb526e3949ee8cd152ca487e75.zip
sys-apps/sandbox: add 2.34
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps/sandbox')
-rw-r--r--sys-apps/sandbox/Manifest1
-rw-r--r--sys-apps/sandbox/sandbox-2.34.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index 499adc1562b1..04eda7314410 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -3,3 +3,4 @@ DIST sandbox-2.30.tar.xz 455764 BLAKE2B eb3bf46aedda96154a96f31d31469b394fd7ea11
DIST sandbox-2.31.tar.xz 456368 BLAKE2B 054b0ae229d64a4c9553a8ace64ccf2f1e1fee4c545a5b4135d363368e800f3e3af8930916411e8ef4836f437225ae9f092c1c8d39742482a44029832592590d SHA512 0b97c0e77bee58c50cf5aad6d158be546424bf4bc5f2e9ddd4322ca46c003ddca127c303fbe615ad2fefe519498c7221c5315d3ad98a947ea545c0640bc60649
DIST sandbox-2.32.tar.xz 456724 BLAKE2B 95eed293ef9427726f62d0d7ac1a0c63bbfd152d71598f6c5f792c8b818999c98600f4d8c71b92c8a90ba9fca595b5619ba408ac5f0edcc012050111d84519e0 SHA512 db0fe755b0bff0888a7861194218e980a73a2c4c0afadb7f0e5bb794dbc8b3d5bfbf7e2510a7167874c9f6fbf7eea428e6eae7b52dcbc91ffbd2aa1b1b54bef8
DIST sandbox-2.33.tar.xz 458764 BLAKE2B 45bd2ffc8aea2f9923880dd494fc648be6d260524706a4166963181a09e005ae74e8069c0d81b5e71ec092ee2767ef2e1206e68614dfb9fe06f3dc77cb5331fe SHA512 c09d4747b9a5a1b964f4c4cc24ed80fea02091bc4c23918689d9f1645bafb7ac0afb5cfcf92ba1eaffe7afbb7f9d9320cdf4e37a59d0f6b472280f11058f9059
+DIST sandbox-2.34.tar.xz 459008 BLAKE2B 19818928d72bf8875667ef69841a7b78643b2b6a02d7d02d6807d3a23ff10fd6821b5fd6b55fc16b213559efb2d010a9930b70c515c55b22285fb4b35aa1a505 SHA512 7be13bb056da6c361f01e35c50a89878bdb356eb7cc167719435e9893c88e1f3b52253f21fc5554d898f782f725f5a78923d7f6835c7dd32a28e993a9fd520f4
diff --git a/sys-apps/sandbox/sandbox-2.34.ebuild b/sys-apps/sandbox/sandbox-2.34.ebuild
new file mode 100644
index 000000000000..1efc83d19f22
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.34.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+nnp"
+
+# pax-utils lower bound for bug #265376
+DEPEND=">=app-misc/pax-utils-0.1.19"
+# Avoid folks installing with older file, bug #889046. We still need the
+# >= dep in Portage but this is a safety net if people do partial upgrades.
+RDEPEND="!<sys-apps/file-5.44-r1"
+BDEPEND="app-arch/xz-utils"
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+src_prepare() {
+ default
+
+ if ! use nnp ; then
+ sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
+ fi
+
+ # sandbox uses `__asm__ (".symver "...` which does
+ # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
+ filter-lto
+}
+
+multilib_src_configure() {
+ filter-lfs-flags #90228
+
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ dodoc AUTHORS ChangeLog* README.md
+}
+
+pkg_postinst() {
+ mkdir -p "${EROOT}"/var/log/sandbox
+ chown root:portage "${EROOT}"/var/log/sandbox
+ chmod 0770 "${EROOT}"/var/log/sandbox
+}