summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-04-13 15:29:35 +0200
committerConrad Kostecki <conikost@gentoo.org>2022-04-13 15:34:40 +0200
commitd6a223bd3f79e17f3365272bd3c99f160079e517 (patch)
tree9ad41ff770aaf92592a24bddd2ce7956b60927d9 /sys-apps/smc-sum
parentapp-emulation/winetricks: Drop old (diff)
downloadgentoo-d6a223bd3f79e17f3365272bd3c99f160079e517.tar.gz
gentoo-d6a223bd3f79e17f3365272bd3c99f160079e517.tar.bz2
gentoo-d6a223bd3f79e17f3365272bd3c99f160079e517.zip
sys-apps/smc-sum: add 2.8.0.20220126
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'sys-apps/smc-sum')
-rw-r--r--sys-apps/smc-sum/Manifest1
-rw-r--r--sys-apps/smc-sum/smc-sum-2.8.0.20220126.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/sys-apps/smc-sum/Manifest b/sys-apps/smc-sum/Manifest
index 66aa10af00c9..1d76459b370a 100644
--- a/sys-apps/smc-sum/Manifest
+++ b/sys-apps/smc-sum/Manifest
@@ -1 +1,2 @@
DIST sum_2.7.0_Linux_x86_64_20210903.tar.gz 13796908 BLAKE2B 4ea3e63be33bb94724483db3f5a4476f1f866152f03572e9b32317f7cc3b44b04d91a20965e6a63c7d3c5c6f5b2a4b493f77fef981d4813dfbf5c5dc2684d23a SHA512 d55a0a28a5700179f2acdd51a45be490c841b4ad3e01df30bdb22d02ccc0e24265205b320be2c5feef328e53cc049fb59376afc122707694fd17dd6c35658a9b
+DIST sum_2.8.0_Linux_x86_64_20220126.tar.gz 14852916 BLAKE2B a65243878ec41c05fc8c71f147883fea29517e93ef0e1460a39827a98e1fd9e533be2f4a6cfceed29562ba2d0e798cac64645bbf4d2b23267396d86516277df9 SHA512 4e11a9916b3386229eb5cfc15830bd1ecab7d79cdc3280f4a736b8882554170e6d1579531c441d0966c816e1f9c98d256d7fbb2c0a6e8c03770a1053860a06f5
diff --git a/sys-apps/smc-sum/smc-sum-2.8.0.20220126.ebuild b/sys-apps/smc-sum/smc-sum-2.8.0.20220126.ebuild
new file mode 100644
index 000000000000..e309a7ad7f47
--- /dev/null
+++ b/sys-apps/smc-sum/smc-sum-2.8.0.20220126.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod
+
+MY_DATE="$(ver_cut 4)"
+MY_PN="${PN/smc-/}"
+MY_PV="$(ver_cut 1-3)"
+
+DESCRIPTION="Updates the BIOS and IPMI firmware and system settings on Supermicro mainboards"
+HOMEPAGE="https://www.supermicro.com"
+SRC_URI="${MY_PN}_${MY_PV}_Linux_x86_64_${MY_DATE}.tar.gz"
+S="${WORKDIR}/${MY_PN}_${MY_PV}_Linux_x86_64"
+
+LICENSE="supermicro"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="module"
+
+RDEPEND="
+ sys-libs/zlib
+ sys-power/iasl
+ module? ( !sys-apps/smc-sum-driver )
+"
+
+RESTRICT="bindist fetch mirror"
+
+DOCS=(
+ "PlatformFeatureSupportMatrix.pdf"
+ "ReleaseNote.txt"
+ "SUM_UserGuide.pdf"
+ "sumrc.sample"
+ "ExternalData/SMCIPID.txt"
+ "ExternalData/VENID.txt"
+)
+
+PATCHES=( "${FILESDIR}/${PN}-2.7.0.20210903-missing-include.patch" )
+
+BUILD_TARGETS="default"
+MODULE_NAMES="sum_bios(misc:${S}/driver/Source/Linux)"
+
+QA_PREBUILT="usr/bin/smc-sum"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.supermicro.com/SwDownload/UserInfo.aspx?sw=0&cat=SUM"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ default
+
+ # Install new Makefile to respect users CFLAGS and LDFLAGS
+ cp "${FILESDIR}"/makefile driver/Source/Linux/Makefile || die
+}
+
+src_compile() {
+ if use module; then
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}/driver/Source/Linux"
+ linux-mod_src_compile
+ else
+ :;
+ fi
+}
+
+src_install() {
+ newbin sum smc-sum
+ einstalldocs
+
+ use module && linux-mod_src_install
+}