summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-14 03:18:33 +0100
committerSam James <sam@gentoo.org>2023-09-14 03:18:33 +0100
commita530eb845602c26c32cdc08f47b906c9c843eca1 (patch)
tree0983a5fb3bb5cd2264ccc6cd7a00f4b6c9a65b68 /sys-apps/texinfo
parentsys-fs/btrfs-progs: add 6.5.1 (diff)
downloadgentoo-a530eb845602c26c32cdc08f47b906c9c843eca1.tar.gz
gentoo-a530eb845602c26c32cdc08f47b906c9c843eca1.tar.bz2
gentoo-a530eb845602c26c32cdc08f47b906c9c843eca1.zip
sys-apps/texinfo: add 7.0.92
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-7.0.92.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index a89aef3b1741..b44a221858e3 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -3,3 +3,4 @@ DIST texinfo-7.0.2.tar.xz 4875424 BLAKE2B 23737cc800392c949add14c1d0a01a294e8c22
DIST texinfo-7.0.3.tar.xz 4886668 BLAKE2B 38710faba2f717f7990228d58924901ea7d7378cc02e2059a437b5127f9e2dc67f732584e3f45fc34e8ef6d7671a546fe66871dadbd29e772f3417768622a650 SHA512 7d14f7458f2b7d0ee0b740e00a5fc2a9d61d33811aa5905d649875ec518dcb4f01be46fb0c46748f7dfe36950597a852f1473ab0648d5add225bc8f35528a8ff
DIST texinfo-7.0.90.tar.xz 5474032 BLAKE2B 6578671213309a6d0ee5fa6eec8d4515416d0fc7c9e37a741309caeffecb970796dfb9b7164f5377fcc368ecf1fa0bbaff46ed5345afdcc17fd0e624ee0cf47b SHA512 cfff7e340c211488cb38d0acdfea54d1c74007f3deeadedb097741225c54eb3c13a05811426807f75d4b517b7e4bdd21238f06e6ceabfe8e7ae73a9b753800af
DIST texinfo-7.0.91.tar.xz 5513076 BLAKE2B 4dbadb9f36b7bb55282db33080b9bb7afd0bb275190bd8fb3a05474d45e3d33f06371b91b32012cee5e21f8632cec3b7f6b1de30c87231fc0d9a1bc80bb7ae77 SHA512 c6687e4300c14d8ad1a25099db66dc05440ea1b6c89803f30adde337bfdd25a3d3d91e80ec47e8930c6898ec0a022dd02e4e205d31233644d2d783b1c1be9bcc
+DIST texinfo-7.0.92.tar.xz 5513304 BLAKE2B 0661ac8f148319097c7226bda25bad4c1ae611240d5d275847be339adb13055d6b543a09447a16040ae27ea0054f1978f4c49c5fc9eb3576ac6c83380c038401 SHA512 89f0d32fa4f380afa714c96be0f75972821f746b23557a58e570f7f73a5f7e5fc3f411045582b7147c57c7bc3543c0afd3e6972018849d9725cc672e6442cf78
diff --git a/sys-apps/texinfo/texinfo-7.0.92.ebuild b/sys-apps/texinfo/texinfo-7.0.92.ebuild
new file mode 100644
index 000000000000..7c36a9271893
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-7.0.92.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/texinfo.git"
+ REGEN_BDEPEND="
+ >=sys-devel/autoconf-2.62
+ >=sys-devel/automake-1.16
+ sys-devel/libtool
+ "
+elif [[ $(ver_cut 3) -ge 90 || $(ver_cut 4) -ge 90 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+ REGEN_BDEPEND=""
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ REGEN_BDEPEND=""
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:=
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ virtual/perl-Unicode-Collate
+ standalone? ( >=dev-lang/perl-5.8.1 )
+ !standalone? (
+ >=dev-lang/perl-5.8.1:=
+ dev-libs/libunistring:=
+ )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${REGEN_BDEPEND}
+ nls? ( >=sys-devel/gettext-0.19.6 )
+"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ ./autogen.sh || die
+ fi
+
+ # Needed if a patch touches install-info.c
+ #touch man/install-info.1 || die
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch {doc,man}/{texi2dvi,texi2pdf,pdftexi2dvi}.1 || die
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions
+ # bug #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}"
+ local -x PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+
+ # TODO:
+ # --with-external-Unicode-EastAsianWidth
+ # --with-external-Text-Unidecode
+ #
+ # Also, 7.0.91 seemed to introduce a included-libunistring w/ USE=-standalone
+ # but it doesn't seem to do anything?
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ $(use_enable nls)
+ $(use_enable !standalone perl-xs)
+ )
+
+ econf "${myeconfargs[@]}"
+}