summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/unscd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/unscd')
-rw-r--r--sys-apps/unscd/Manifest2
-rw-r--r--sys-apps/unscd/files/unscd-tmpfiles.conf1
-rwxr-xr-xsys-apps/unscd/files/unscd.initd40
-rw-r--r--sys-apps/unscd/files/unscd.initd-r116
-rw-r--r--sys-apps/unscd/files/unscd.service18
-rw-r--r--sys-apps/unscd/metadata.xml5
-rw-r--r--sys-apps/unscd/unscd-0.51.ebuild35
-rw-r--r--sys-apps/unscd/unscd-0.52-r2.ebuild37
8 files changed, 154 insertions, 0 deletions
diff --git a/sys-apps/unscd/Manifest b/sys-apps/unscd/Manifest
new file mode 100644
index 000000000000..6e55ad97e79a
--- /dev/null
+++ b/sys-apps/unscd/Manifest
@@ -0,0 +1,2 @@
+DIST nscd-0.51.c 73007 SHA256 c915df72749c3fa89baa81291f40bd529512d28d484a75bcb9f8de053f9884ff SHA512 e506eca97f430191507bf41e7c9a696354bfaf14eb754467d007273931e47cef323f1ddbeffb48579c9a9a393a0256bd925576f3c88f9596879dd376b67c95fb WHIRLPOOL 9006c68a1154cd76e85b7177dd5cca301dfd3e95654f9cc6beb1a6ca4623c097b12163a135462355363bf72ef973478590380e2631b2340aed827c955ec34ac8
+DIST nscd-0.52.c 73144 SHA256 4c1f83dcd120469fceef749050cb29fa666fa4666bd308dfe92e933a4c200d55 SHA512 ba48410309fced9b8d9f929c52b39ca9a8caaf451fe73742bde7d4a4ab9980bc0f353551e19c846e96d6cb8a71e3c5edc7ddddf76cce0613282f0d01fde0612f WHIRLPOOL d98e305ee99da16e50dc379991fa3083f9608cb4ae9fbd50f03f50c0ae3d2eae8dc352fdc7fa690e47b36edd7b9c8c7cb029bd69c579d07310481b742634f0cd
diff --git a/sys-apps/unscd/files/unscd-tmpfiles.conf b/sys-apps/unscd/files/unscd-tmpfiles.conf
new file mode 100644
index 000000000000..b5f25f6c5bb1
--- /dev/null
+++ b/sys-apps/unscd/files/unscd-tmpfiles.conf
@@ -0,0 +1 @@
+d /run/nscd 0755 root root -
diff --git a/sys-apps/unscd/files/unscd.initd b/sys-apps/unscd/files/unscd.initd
new file mode 100755
index 000000000000..3fcb52b2c9c8
--- /dev/null
+++ b/sys-apps/unscd/files/unscd.initd
@@ -0,0 +1,40 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ use dns ldap net slapd
+}
+
+checkconfig() {
+ if [ ! -d /var/run/nscd ] ; then
+ mkdir -p /var/run/nscd
+ chmod 755 /var/run/nscd
+ fi
+ if [ -z "${NSCD_PERMS_OK}" ] && [ "$(stat -c %a /var/run/nscd)" != "755" ] ; then
+ echo ""
+ ewarn "nscd run dir is not world readable, you should reset the perms:"
+ ewarn "chmod 755 /var/run/nscd"
+ ewarn "chmod a+rw /var/run/nscd/socket"
+ echo ""
+ ewarn "To disable this warning, set 'NSCD_PERMS_OK=1' in /etc/conf.d/unscd"
+ echo ""
+ fi
+}
+
+start() {
+ checkconfig
+
+ ebegin "Starting Name Service Cache Daemon (unscd)"
+ start-stop-daemon --start --quiet \
+ --exec /usr/sbin/unscd --pidfile /var/run/nscd/nscd.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down Name Service Cache Daemon (unscd)"
+ start-stop-daemon --stop --quiet \
+ --exec /usr/sbin/unscd --pidfile /var/run/nscd/nscd.pid
+ eend $?
+}
diff --git a/sys-apps/unscd/files/unscd.initd-r1 b/sys-apps/unscd/files/unscd.initd-r1
new file mode 100644
index 000000000000..55262fdfb11a
--- /dev/null
+++ b/sys-apps/unscd/files/unscd.initd-r1
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+name="Name Service Cache Daemon (unscd)"
+command="/usr/sbin/unscd"
+pidfile="/run/nscd/nscd.pid"
+
+depend() {
+ use dns ldap net slapd
+}
+
+start_pre() {
+ checkpath -d --quiet --mode 755 /run/nscd
+}
diff --git a/sys-apps/unscd/files/unscd.service b/sys-apps/unscd/files/unscd.service
new file mode 100644
index 000000000000..d7c932b9587d
--- /dev/null
+++ b/sys-apps/unscd/files/unscd.service
@@ -0,0 +1,18 @@
+[Unit]
+Description=Name Service Cache Daemon (unscd)
+Wants=ldap.service network-online.target slapd.service
+After=ldap.service network-online.target nss-lookup.target nss-user-lookup.target slapd.service
+
+[Service]
+Type=forking
+PIDFile=/run/nscd/nscd.pid
+ExecStart=/usr/sbin/unscd
+ExecStop=/usr/sbin/nscd --shutdown
+ExecReload=/usr/sbin/nscd -i passwd
+ExecReload=/usr/sbin/nscd -i group
+ExecReload=/usr/sbin/nscd -i hosts
+ExecReload=/usr/sbin/nscd -i services
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-apps/unscd/metadata.xml b/sys-apps/unscd/metadata.xml
new file mode 100644
index 000000000000..686dc818edb9
--- /dev/null
+++ b/sys-apps/unscd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>toolchain</herd>
+</pkgmetadata>
diff --git a/sys-apps/unscd/unscd-0.51.ebuild b/sys-apps/unscd/unscd-0.51.ebuild
new file mode 100644
index 000000000000..a2375ee106cf
--- /dev/null
+++ b/sys-apps/unscd/unscd-0.51.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple & stable nscd replacement"
+HOMEPAGE="http://busybox.net/~vda/unscd/README"
+SRC_URI="http://busybox.net/~vda/unscd/nscd-${PV}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc[nscd(+)]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/nscd-${PV}.c unscd.c || die
+}
+
+src_compile() {
+ tc-export CC
+ emake unscd
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/unscd.initd unscd
+ dosbin unscd
+}
diff --git a/sys-apps/unscd/unscd-0.52-r2.ebuild b/sys-apps/unscd/unscd-0.52-r2.ebuild
new file mode 100644
index 000000000000..4127deb95d78
--- /dev/null
+++ b/sys-apps/unscd/unscd-0.52-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="simple & stable nscd replacement"
+HOMEPAGE="http://busybox.net/~vda/unscd/README"
+SRC_URI="http://busybox.net/~vda/unscd/nscd-${PV}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc[nscd(+)]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/nscd-${PV}.c ${PN}.c || die
+}
+
+src_compile() {
+ tc-export CC
+ emake unscd
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/unscd.initd-r1 unscd
+ systemd_newtmpfilesd "${FILESDIR}"/unscd-tmpfiles.conf unscd.conf
+ systemd_dounit "${FILESDIR}"/unscd.service
+ dosbin unscd
+}