summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <ya@sysdump.net>2018-05-20 23:29:00 -0700
committerSergei Trofimovich <slyfox@gentoo.org>2018-05-21 08:30:27 +0100
commit9aad2349e87823ec4d666d88841578a3bb41e1c3 (patch)
treed130dd6c15adcb2b2482b2355f72350dee871a0c /sys-apps/unscd
parentprofiles: stable-mask dev-python/s3fs[test] (diff)
downloadgentoo-9aad2349e87823ec4d666d88841578a3bb41e1c3.tar.gz
gentoo-9aad2349e87823ec4d666d88841578a3bb41e1c3.tar.bz2
gentoo-9aad2349e87823ec4d666d88841578a3bb41e1c3.zip
sys-apps/unscd: bump to 0.53
Also switch EAPI to 6 Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8504
Diffstat (limited to 'sys-apps/unscd')
-rw-r--r--sys-apps/unscd/Manifest1
-rw-r--r--sys-apps/unscd/unscd-0.53.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/unscd/Manifest b/sys-apps/unscd/Manifest
index f6bd802d7727..d78436cd2f08 100644
--- a/sys-apps/unscd/Manifest
+++ b/sys-apps/unscd/Manifest
@@ -1 +1,2 @@
DIST nscd-0.52.c 73144 BLAKE2B 962c619044d54d3136ce2cd3f4766a0a5a11b0f341fb595238332ec4ef521854f6ef60c846ae0c8e3069774361366b6b53c1b48c8d21ebdf11b42bf05677852a SHA512 ba48410309fced9b8d9f929c52b39ca9a8caaf451fe73742bde7d4a4ab9980bc0f353551e19c846e96d6cb8a71e3c5edc7ddddf76cce0613282f0d01fde0612f
+DIST nscd-0.53.c 73206 BLAKE2B ce3b8e02ce8879664bde7ee7362ee0d920ad9e9cd24da08b02e83d49b2e0bef7fb1b3c6635bc4e8a26d901170943a78bae608903459e4447edf004e5ef716468 SHA512 d14362d21282d0ea919af3b353f7838d1514c293b49df084bc8df424392b4121dba3443a07118f4c8c1cfdca0cbf8ebddde24cf73459b06349e9d1a68801403c
diff --git a/sys-apps/unscd/unscd-0.53.ebuild b/sys-apps/unscd/unscd-0.53.ebuild
new file mode 100644
index 000000000000..d191aa03c5e6
--- /dev/null
+++ b/sys-apps/unscd/unscd-0.53.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit systemd toolchain-funcs
+
+DESCRIPTION="simple & stable nscd replacement"
+HOMEPAGE="https://busybox.net/~vda/unscd/README"
+SRC_URI="https://busybox.net/~vda/unscd/nscd-${PV}.c"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/glibc[nscd(+)]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp "${DISTDIR}"/nscd-${PV}.c ${PN}.c || die
+}
+
+src_compile() {
+ tc-export CC
+ emake unscd
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/unscd.initd-r1 unscd
+ systemd_newtmpfilesd "${FILESDIR}"/unscd-tmpfiles.conf unscd.conf
+ systemd_dounit "${FILESDIR}"/unscd.service
+ dosbin unscd
+}