summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-28 03:38:05 +0000
committerSam James <sam@gentoo.org>2023-01-28 03:38:07 +0000
commita476c8790b1af7e68090acf82fd18dea8bb04daa (patch)
tree04ea298e66ec5a7d4516f0e2378ef96b19254774 /sys-apps/usbguard
parentprofiles: mask app-admin/bastille for removal (diff)
downloadgentoo-a476c8790b1af7e68090acf82fd18dea8bb04daa.tar.gz
gentoo-a476c8790b1af7e68090acf82fd18dea8bb04daa.tar.bz2
gentoo-a476c8790b1af7e68090acf82fd18dea8bb04daa.zip
sys-apps/usbguard: fix build w/ gcc 13
There's another PR upstream which drops a redundant include but I'd rather just go with the obviously-correct one (as adding an include like this isn't going to be a problem for standard headers guarded properly) to unblock more testing. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/usbguard')
-rw-r--r--sys-apps/usbguard/files/usbguard-1.1.2-gcc-13.patch19
-rw-r--r--sys-apps/usbguard/usbguard-1.1.2.ebuild6
2 files changed, 24 insertions, 1 deletions
diff --git a/sys-apps/usbguard/files/usbguard-1.1.2-gcc-13.patch b/sys-apps/usbguard/files/usbguard-1.1.2-gcc-13.patch
new file mode 100644
index 000000000000..79168f584ded
--- /dev/null
+++ b/sys-apps/usbguard/files/usbguard-1.1.2-gcc-13.patch
@@ -0,0 +1,19 @@
+https://github.com/USBGuard/usbguard/pull/582
+
+From a0083fd0eea3a513613a37262d40dfbe96e02e46 Mon Sep 17 00:00:00 2001
+From: Yaakov Selkowitz <yselkowi@redhat.com>
+Date: Tue, 24 Jan 2023 14:54:28 -0500
+Subject: [PATCH] Fix compile with GCC 13
+
+Signed-off-by: Yaakov Selkowitz <yselkowi@redhat.com>
+--- a/src/Library/Base64.hpp
++++ b/src/Library/Base64.hpp
+@@ -24,6 +24,7 @@
+
+ #include <string>
+ #include <cstddef>
++#include <cstdint>
+
+ namespace usbguard
+ {
+
diff --git a/sys-apps/usbguard/usbguard-1.1.2.ebuild b/sys-apps/usbguard/usbguard-1.1.2.ebuild
index 77e050da627a..d3722e624db9 100644
--- a/sys-apps/usbguard/usbguard-1.1.2.ebuild
+++ b/sys-apps/usbguard/usbguard-1.1.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -52,6 +52,10 @@ DEPEND="${CDEPEND}
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.2-gcc-13.patch
+)
+
src_prepare() {
default
eautoreconf