summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-08-26 16:53:23 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-01-07 18:19:08 +0100
commitd6273a925f45d0453bab0f0e795670962c881f9e (patch)
tree596510ae556b09229c8782c217e32c2642bcdc53 /sys-block
parentsys-block/sas2ircu: rename USE=efi to USE=uefi (diff)
downloadgentoo-d6273a925f45d0453bab0f0e795670962c881f9e.tar.gz
gentoo-d6273a925f45d0453bab0f0e795670962c881f9e.tar.bz2
gentoo-d6273a925f45d0453bab0f0e795670962c881f9e.zip
sys-block/sas3flash: rename USE=efi to USE=uefi
Signed-off-by: David Seifert <soap@gentoo.org> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/sas3flash/metadata.xml2
-rw-r--r--sys-block/sas3flash/sas3flash-16.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/sys-block/sas3flash/metadata.xml b/sys-block/sas3flash/metadata.xml
index 55d75d1768a2..c4392c4ef605 100644
--- a/sys-block/sas3flash/metadata.xml
+++ b/sys-block/sas3flash/metadata.xml
@@ -6,6 +6,6 @@
<name>Zac Medico</name>
</maintainer>
<use>
- <flag name="efi">Install EFI variant as well</flag>
+ <flag name="uefi">Install UEFI variant as well</flag>
</use>
</pkgmetadata>
diff --git a/sys-block/sas3flash/sas3flash-16.ebuild b/sys-block/sas3flash/sas3flash-16.ebuild
index 94f85c44952a..235774821fde 100644
--- a/sys-block/sas3flash/sas3flash-16.ebuild
+++ b/sys-block/sas3flash/sas3flash-16.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit mount-boot secureboot
DESCRIPTION="Flash utility for LSI MPT-SAS3 controller"
@@ -10,7 +11,7 @@ HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9300-8
LICENSE="LSI"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86 ~x64-solaris"
-IUSE="doc efi"
+IUSE="doc uefi"
RESTRICT="strip fetch mirror"
BDEPEND="app-arch/unzip"
@@ -31,7 +32,7 @@ SRC_URI="
x86? ( ${SRC_URI_LINUX} )
ppc64? ( ${SRC_URI_LINUX} )
x64-solaris? ( ${SRC_URI_SOLARIS} )
- efi? ( ${SRC_URI_UEFI} )
+ uefi? ( ${SRC_URI_UEFI} )
doc? ( "${SRC_URI_BASE}/oracle/files/${DISTFILE_DOC}" )"
S="${WORKDIR}"
@@ -48,7 +49,7 @@ pkg_nofetch() {
}
pkg_setup() {
- use efi && secureboot_pkg_setup
+ use uefi && secureboot_pkg_setup
}
supportedcards() {
@@ -86,7 +87,7 @@ src_install() {
DOCS+=( Installer_P"${PV}"_for_Solaris/README_Installer_P"${PV}"_Solaris.txt )
fi
- if use efi; then
+ if use uefi; then
exeinto /boot/efi/
DOCS+=( Installer_P"${PV}"_for_UEFI/README_Installer_P"${PV}"_UEFI.txt )
if use amd64; then