summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-11-12 22:51:12 -0800
committerMatt Turner <mattst88@gentoo.org>2019-11-12 22:53:14 -0800
commit870fda96e30afeaf24a7b0159be2401454030958 (patch)
tree8f2b8729c16bbcedeb357227637159f770fa75a2 /sys-boot/milo
parentdev-ruby/actionpack-action_caching: add 1.2.1 (diff)
downloadgentoo-870fda96e30afeaf24a7b0159be2401454030958.tar.gz
gentoo-870fda96e30afeaf24a7b0159be2401454030958.tar.bz2
gentoo-870fda96e30afeaf24a7b0159be2401454030958.zip
sys-boot/milo: Port to EAPI=7
Closes: https://bugs.gentoo.org/697180 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-boot/milo')
-rw-r--r--sys-boot/milo/milo-2.4.18.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/sys-boot/milo/milo-2.4.18.ebuild b/sys-boot/milo/milo-2.4.18.ebuild
index 3902314970fb..e6bee2b3f6c6 100644
--- a/sys-boot/milo/milo-2.4.18.ebuild
+++ b/sys-boot/milo/milo-2.4.18.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit flag-o-matic eutils
@@ -87,12 +87,16 @@ src_unpack() {
# unpack everything the kernel and milo sources
unpack linux-${kernel_version}.tar.bz2
unpack milo-${milo_version}.tar.bz2
+ unpack linux-2.2.20-reiserfs-3.5.35.diff.bz2
+}
+src_prepare() {
# gcc3 fixes, and some tweaks to get a build, also
# reiserfs support for the kernel (and milo).
- cd ${WORKDIR}/linux; epatch "${FILESDIR}"/linux-${kernel_version}-gcc3-milo.diff || die
- cd ${WORKDIR}/linux; epatch "${DISTDIR}"/linux-2.2.20-reiserfs-3.5.35.diff.bz2 || die
- cd ${S}; epatch "${FILESDIR}"/milo-${milo_version}-gcc3-gentoo.diff || die
+ cd ${WORKDIR}/linux; eapply "${FILESDIR}"/linux-${kernel_version}-gcc3-milo.diff || die
+ cd ${WORKDIR}/linux; eapply "${WORKDIR}"/linux-2.2.20-reiserfs-3.5.35.diff || die
+ cd ${S}; eapply "${FILESDIR}"/milo-${milo_version}-gcc3-gentoo.diff || die
+ eapply_user
}
src_compile() {
@@ -149,9 +153,6 @@ src_compile() {
einfo "i will use it instead of the default."
ewarn
- einfon "continuing in 10 seconds ..."
- epause 10
-
# get kernel configured
cp ${custom_milo_kernel_config:-${S}/Documentation/config/linux-2.2.19-SuSE.config} \
${WORKDIR}/linux/.config