summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-04-21 15:42:42 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-04-22 13:32:30 +0200
commit664309ea6b95b80d91c5c58ddc68d4cfb6aedab4 (patch)
tree4cc5391a98eff0ce0783f567424c4e9632cec27d /sys-boot/uefi-mkconfig
parentdev-python/pyarrow: Deselect more hypothesis-flaky tests (diff)
downloadgentoo-664309ea6b95b80d91c5c58ddc68d4cfb6aedab4.tar.gz
gentoo-664309ea6b95b80d91c5c58ddc68d4cfb6aedab4.tar.bz2
gentoo-664309ea6b95b80d91c5c58ddc68d4cfb6aedab4.zip
sys-boot/uefi-mkconfig: add 1.5
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/36343 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot/uefi-mkconfig')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index dfaeef8f744c..a88d8a60c4ff 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1 +1,2 @@
DIST uefi-mkconfig-1.4.tar.gz 7844 BLAKE2B 4266c8c934f665c85d54699ebdd11648692b1eff2e0d4111de8329e01dee3342c760d772da27a8862e0427fcbecb38a9c0499ee482aa1ee0dcf72d0f30be97ef SHA512 47e096571899c18decd24c65df9bdd9da964e1e47120504d8c9761b7c2b80172b17a9259f229c267c95d7ee4ac24a1e79a3d0f13d15fc2effee7fcee8b1ce3ea
+DIST uefi-mkconfig-1.5.tar.gz 8299 BLAKE2B f06ec90f298f2dcc5c3001f603b50c7521b5568272ba263b87f19ed45f5d10aec162b8ad909c9c5bbe72638559b9346f586063e7e25c33c7b41b3fe881bab35f SHA512 244d280a0b2b8e197b9d9a46e4db729efb5d568a0907c538aa1e27e0491eb12e2105bfc6d7b52c2a06f7fd53f7c5d339d680124a9dbfb5bd451b8659ea23752f
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild
new file mode 100644
index 000000000000..8e426c062c9c
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-1.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}