summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-03-21 15:09:59 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-03-21 15:10:30 +0000
commitb02e140454b97001ae09db7496cabfd6a093bbe3 (patch)
treed96ed7df8144f5dbb286a96168b20beee5594de3 /sys-process/memwatch
parentdev-util/dwdiff: EAPI 6 bump. (diff)
downloadgentoo-b02e140454b97001ae09db7496cabfd6a093bbe3.tar.gz
gentoo-b02e140454b97001ae09db7496cabfd6a093bbe3.tar.bz2
gentoo-b02e140454b97001ae09db7496cabfd6a093bbe3.zip
sys-process/memwatch: EAPI 6 bump.
Package-Manager: portage-2.2.26
Diffstat (limited to 'sys-process/memwatch')
-rw-r--r--sys-process/memwatch/memwatch-0.0.2-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.0.2-r1.ebuild b/sys-process/memwatch/memwatch-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..7ac38fbafd84
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.0.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://bitbucket.org/PascalRD/memwatch/"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ einfo "Regenerating autotools files..."
+ ./autogen.sh || die "autogen failed"
+}
+
+src_configure() {
+ econf
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}