summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-13 12:34:45 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-13 12:36:22 +0000
commitdd9527dbb15fe1e0ce021c787054593bf19af822 (patch)
tree17feffcf2e31041f37ca56847c8f8563fadd287b /sys-process/memwatch
parentdev-libs/bglibs: x86 stable wrt bug #453310 (diff)
downloadgentoo-dd9527dbb15fe1e0ce021c787054593bf19af822.tar.gz
gentoo-dd9527dbb15fe1e0ce021c787054593bf19af822.tar.bz2
gentoo-dd9527dbb15fe1e0ce021c787054593bf19af822.zip
sys-process/memwatch: Remove default curses module.
The CMake curses module shipped with memwatch is buddy and prevents CMake from performing a proper linking against ncurses. To work around this issue, remove it so that CMake can find the correct ncurses library installed on the system and link the resulting memwatch binary correctly against it. Gentoo-Bug: https://bugs.gentoo.org/585802 Package-Manager: portage-2.2.28
Diffstat (limited to 'sys-process/memwatch')
-rw-r--r--sys-process/memwatch/memwatch-0.3.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/memwatch/memwatch-0.3.0-r1.ebuild b/sys-process/memwatch/memwatch-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..804b28eaef3d
--- /dev/null
+++ b/sys-process/memwatch/memwatch-0.3.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Interactive memory viewer"
+HOMEPAGE="https://unixdev.ru/memwatch"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+CMAKE_REMOVE_MODULES_LIST="FindCurses"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}