summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-12 12:35:46 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-12 15:27:48 +0100
commit135cb06754e814d6d123ecbee6995aec03131854 (patch)
treedce706f3a6629287626e215af61b4a97ce27b03b /www-client
parentdev-cpp/atkmm: Version bump (diff)
downloadgentoo-135cb06754e814d6d123ecbee6995aec03131854.tar.gz
gentoo-135cb06754e814d6d123ecbee6995aec03131854.tar.bz2
gentoo-135cb06754e814d6d123ecbee6995aec03131854.zip
www-client/epiphany: Version bump, pax marking on epiphany is not required anymore (#522810 by Alexander Tsoy)
Package-Manager: portage-2.2.24
Diffstat (limited to 'www-client')
-rw-r--r--www-client/epiphany/Manifest1
-rw-r--r--www-client/epiphany/epiphany-3.18.2.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/www-client/epiphany/Manifest b/www-client/epiphany/Manifest
index 11e44fe53d5e..1cac55e37617 100644
--- a/www-client/epiphany/Manifest
+++ b/www-client/epiphany/Manifest
@@ -1,2 +1,3 @@
DIST epiphany-3.16.3.tar.xz 3082680 SHA256 d527f1770779ec22d955aeb13b148a846a26144e433ff0480c981af80e2390b1 SHA512 68f4dc0e299b929f244818d93a9af14f48ef2c3a93813fe5457c11d37ddb5a5e2b5ae3f93f0d41e8095590f87d8679d2cee5b6298c128475a9ad9eb6aa3c8bae WHIRLPOOL c82ff5051ac3c1ac2480b846f77893f39f52517f0aa0f7a6084e8b24e98f490264a6adecd89671d89719da835ca84f0613019e281280380bb20d980c2294afe9
DIST epiphany-3.18.0.tar.xz 3086780 SHA256 d5ba67a8cd85c80b81e076862bcab3fc376ba51b0a1536ca7430608d1f50491d SHA512 16cf080c7aa7f4ec62ec4e143b9407a41ef6f546b2c5e5263a90b72c73ceaf01007dd5047ca3ae79e9418d0484aca0c972cfe640cfdb1314fff709978d1720e2 WHIRLPOOL 61cb7f74d1e1ac188c4c6ae761da5633ee219305847a4e3d7b27299a59229756f3bcc2fede9c625694cb4553a87ba173cc6b2445f06b6a86fe8b13a0355af31d
+DIST epiphany-3.18.2.tar.xz 3091980 SHA256 8436170731966bb40b7d8e29dbedfa5d5ddbf78572cf5fd51fce1ac6da5da6c2 SHA512 a230f489b2d30cba0682333b1c26a53d223b5d00ac3a0255d0bdc505ee2d3ccb3fa114c290241e601e4af64b39224ee90eea1063e6ba0818f83fb914831382d8 WHIRLPOOL b9d1ec410fff4815ef0e5526bcfbb9670962fd89ea5212a9956996996d64d07ec882212276eaa1734dcc79e466e3d888130b51cd4ade61409419539d38d46fc4
diff --git a/www-client/epiphany/epiphany-3.18.2.ebuild b/www-client/epiphany/epiphany-3.18.2.ebuild
new file mode 100644
index 000000000000..9c16698c267d
--- /dev/null
+++ b/www-client/epiphany/epiphany-3.18.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="GNOME webbrowser based on Webkit"
+HOMEPAGE="https://wiki.gnome.org/Apps/Web"
+
+# TODO: coverage
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nss test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+
+COMMON_DEPEND="
+ >=app-crypt/gcr-3.5.5
+ >=app-crypt/libsecret-0.14
+ >=app-text/iso-codes-0.35
+ >=dev-libs/glib-2.38:2[dbus]
+ >=dev-libs/libxml2-2.6.12:2
+ >=dev-libs/libxslt-1.1.7
+ >=gnome-base/gsettings-desktop-schemas-0.0.1
+ >=net-dns/avahi-0.6.22[dbus]
+ >=net-libs/webkit-gtk-2.9.5:4
+ >=net-libs/libsoup-2.48:2.4
+ >=x11-libs/gtk+-3.13:3
+ >=x11-libs/libnotify-0.5.1:=
+ gnome-base/gnome-desktop:3=
+
+ dev-db/sqlite:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+
+ x11-themes/adwaita-icon-theme
+
+ nss? ( dev-libs/nss )
+"
+# epiphany-extensions support was removed in 3.7; let's not pretend it still works
+RDEPEND="${COMMON_DEPEND}
+ !www-client/epiphany-extensions
+"
+# paxctl needed for bug #407085
+# eautoreconf requires gnome-common-3.5.5
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=gnome-base/gnome-common-3.6
+ dev-libs/appstream-glib
+ >=dev-util/intltool-0.50
+ dev-util/itstool
+ sys-apps/paxctl
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Fix unittests
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751591
+ epatch "${FILESDIR}"/${PN}-3.16.0-unittest-1.patch
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=751593
+ epatch "${FILESDIR}"/${PN}-3.14.0-unittest-2.patch
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-shared \
+ --disable-static \
+ --with-distributor-name=Gentoo \
+ $(use_enable nss) \
+ $(use_enable test tests)
+}
+
+src_compile() {
+ # needed to avoid "Command line `dbus-launch ...' exited with non-zero exit status 1"
+ unset DISPLAY
+ gnome2_src_compile
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DISPLAY
+ GSETTINGS_SCHEMA_DIR="${S}/data" Xemake check
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog* NEWS README TODO"
+ gnome2_src_install
+}