summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-04-15 21:21:35 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-04-15 21:34:16 +0200
commit2fec241acfc052a90d1274f8432286110be9988e (patch)
tree5073b99b7b159d9066692575ea575ab216e79927 /www-misc/urlwatch
parentdev-texlive/texlive-context: remove ia64 keyword (diff)
downloadgentoo-2fec241acfc052a90d1274f8432286110be9988e.tar.gz
gentoo-2fec241acfc052a90d1274f8432286110be9988e.tar.bz2
gentoo-2fec241acfc052a90d1274f8432286110be9988e.zip
www-misc/urlwatch: add 2.23
Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'www-misc/urlwatch')
-rw-r--r--www-misc/urlwatch/Manifest1
-rw-r--r--www-misc/urlwatch/urlwatch-2.23.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index 6302256fb8f8..37a56d0ae7af 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -2,3 +2,4 @@ DIST urlwatch-2.17.tar.gz 44178 BLAKE2B 46163b3305a50c3b5165da8f794c252aeb0a3581
DIST urlwatch-2.18.tar.gz 48268 BLAKE2B e595a6ed27637463f14f92ecafd123eb0c7cef7102cc35ebbc3334804f7e09cc5f933aa2d54e24acd74a1419d6a8683a0d5fb2456b35ae0797c3d8a12efc33de SHA512 4b44a78fe7f2be6f507487ad5de57d79aa55ee790b29b97f2a364c0f3b58828fea5eb2b08235c15cafd3839b9261a7f148ebc9bceb5bedd1ff8319f7f039bb23
DIST urlwatch-2.21.tar.gz 126235 BLAKE2B 9e0f39e51e413355974ce886e019eb86dd07fb9a75c02c5c711ccdbba573c2e6b218cf11b42c714172ad00288ea0219a079fd9b8016d33c29f087537d160e80d SHA512 30d7312c72d839e8ef681a11065f82c2611b650ab1b9b9a33e718bb791712674afb31e4b2e6da97038379fb8cc4ae5bc58b4d0ee6a26c424cba01898b56566b7
DIST urlwatch-2.22.tar.gz 136306 BLAKE2B e7f10872e5d7f42ec0ac1073783431c4b0e4fcdcf40884a9f7f52aee36705fbdbaaf5f9e671223715040c6f68cc580f531ba753c9326a2b1380d2fb707f66f1c SHA512 f2c1e0d279689d1e5761203ba139614b972c6266c30877262d59759b0ce63342a820a063f001039848427ea4af4325505c636762cdedb3dc60ebd09e859914f4
+DIST urlwatch-2.23.tar.gz 137917 BLAKE2B 330c52cad62985d24b2cc4c7345156abe9d5d369f8b3f4402856eb96a98f75422de49045bc10910e5cc81306744aad2dce7c05667a6f4eeb22b2bba47869f260 SHA512 e54f8fe2d8307ca9f2f222e6a2082d517a330db60e410b7c991283a2bf88aa861306965b23ca644811aa69425ec2281f7f48d5e34047b808c0897f45ffc7fcbc
diff --git a/www-misc/urlwatch/urlwatch-2.23.ebuild b/www-misc/urlwatch/urlwatch-2.23.ebuild
new file mode 100644
index 000000000000..4f3817d27e8e
--- /dev/null
+++ b/www-misc/urlwatch/urlwatch-2.23.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool for monitoring webpages for updates"
+HOMEPAGE="https://thp.io/2008/urlwatch/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cssselect[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/minidb[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+distutils_enable_sphinx docs/source dev-python/alabaster
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # Require the pdftotext module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test.pdf-job12]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/pdf-test-password.pdf-job13]"
+ # Require the pytesseract module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job26]"
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/ocr-test.png-job27]"
+ # Requires the jq module
+ "lib/urlwatch/tests/test_filter_documentation.py::test_url[https://example.net/jobs.json-job28]"
+ # Skip code quality check
+ "lib/urlwatch/tests/test_handler.py::test_pep8_conformance"
+ )
+ epytest ${skipped_tests[@]/#/--deselect }
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ if ! has_version dev-python/chump; then
+ elog "Install 'dev-python/chump' to enable Pushover" \
+ "notifications support"
+ fi
+ if ! has_version dev-python/pushbullet-py; then
+ elog "Install 'dev-python/pushbullet-py' to enable" \
+ "Pushbullet notifications support"
+ fi
+ elog "HTML parsing can be improved by installing one of the following packages"
+ elog "and changing the html2text subfilter parameter:"
+ elog "dev-python/beautifulsoup:4"
+ elog "app-text/html2text"
+ elog "dev-python/html2text"
+ elog "www-client/lynx"
+ fi
+}