summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-09-20 15:22:22 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2015-09-20 15:23:23 +0000
commit5e03b3a0040557a0560814ea03d996a11f64ce3f (patch)
treeb230a57a315d61b70aef9690abd106fa860487d9 /www-misc
parentapp-misc/fslint: remove old. (diff)
downloadgentoo-5e03b3a0040557a0560814ea03d996a11f64ce3f.tar.gz
gentoo-5e03b3a0040557a0560814ea03d996a11f64ce3f.tar.bz2
gentoo-5e03b3a0040557a0560814ea03d996a11f64ce3f.zip
Bump awstats to 7.4 release and add patch to fix the unescaped left brace warnings with perl-5.22.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/awstats/Manifest1
-rw-r--r--www-misc/awstats/awstats-7.4.ebuild112
-rw-r--r--www-misc/awstats/files/awstats-perl-5.22.patch45
3 files changed, 158 insertions, 0 deletions
diff --git a/www-misc/awstats/Manifest b/www-misc/awstats/Manifest
index 269c6ec6e8d2..e8640be0ec08 100644
--- a/www-misc/awstats/Manifest
+++ b/www-misc/awstats/Manifest
@@ -1,3 +1,4 @@
DIST awstats-7.1.1.tar.gz 1261038 SHA256 b0051595a38b8b7776f553f20e431760d306bbad1a9e83cf2aca52ef0205f2c0 SHA512 c2bc1604bd15629a057ee7fbbbe4bb0e54992cbd0ed4cd38e4cb9fcbadaa28cd5defd6691352ee8a3f84e98f17b19f9ad953705de4ab36fe4ece95b99b9b685d WHIRLPOOL 37e81b0eb991115b6438f1bf91561c545ae729571de31fd3b46386006027038f2cbed3564f3e9c0dfae6b8fb38f29f05adefe38019ef7deab831c019502da4ca
DIST awstats-7.1_p20121017.tar.gz 1258135 SHA256 262364b77d825096fee088b207f9f6c3d986dddd89645fca53fe09aa8c1fd850 SHA512 171ff3118955c8b73c968a23983885d967632d2c6e95a45f71e5f6fea74afe34d869c9cc901e2e739419068babc96385d7d7df1e8ca10074be7388fbe5c51f53 WHIRLPOOL 678bd6e36634ae2bdee46f42df6d2239a260a188fb1ae07199ef9043a0ad3b54baca7152032873848fabd42f94ef6a92da623e1eb9439d2dbcff15411679f207
DIST awstats-7.3.tar.gz 2921079 SHA256 39b5b1a4406c30874f020b9635b5d6439ac3acbd7612be1abdcfec65e011c100 SHA512 9dfbab607cef02d8e31fd1738a27effb38ad04b22f2f876674879cc95d8fc56d4b0cd280b4e659ac6c20e65393b9365447fe0b851d00e91601d9e4f618530fbd WHIRLPOOL 193759d0e684099a51af65dcff8e056f52951dcec31361e67acc454bf7cd3227e3f64bfaef59a55d7bae81df73ef4c87c3ce203c18d3709e630bd7bbc2d38daa
+DIST awstats-7.4.tar.gz 2936102 SHA256 43abfe7341c2be64f55bb89557347475640ca7ba4473ff30412a3d44358dab55 SHA512 5bce97c71aabeab35e4ff5e5168531e4955d7c1474322c7b4a47d1d06e06ebd0e74d1def73826498e6253f24aeca99309777617b7a914685c927bb6e1c020e1a WHIRLPOOL 8e6872672ec31c73492764414bfbc17ad4b3e295753f301d199d72ccac6df93fcf8969aa792a2de188f20d89a9e4e368f429aa6c9ed38f31ca3415c8fe7899a9
diff --git a/www-misc/awstats/awstats-7.4.ebuild b/www-misc/awstats/awstats-7.4.ebuild
new file mode 100644
index 000000000000..6ea9bca2b8dc
--- /dev/null
+++ b/www-misc/awstats/awstats-7.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+MY_P=${PN}-${PV%_p*}
+
+DESCRIPTION="AWStats is short for Advanced Web Statistics"
+HOMEPAGE="http://www.awstats.org/"
+
+if [ ${MY_P} != ${P} ]; then
+ SRC_URI="https://dev.gentoo.org/~flameeyes/awstats/${P}.tar.gz"
+ # The following SRC_URI is useful only when fetching for the first time
+ # after bump; upstream does not bump the version when they change it, so
+ # we rename it to include the date and upload to our mirrors instead.
+ #SRC_URI="http://www.awstats.org/files/${MY_P}.tar.gz -> ${P}.tar.gz"
+else
+ SRC_URI="http://www.awstats.org/files/${P}.tar.gz"
+fi
+
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="geoip ipv6"
+
+SLOT="0"
+
+RDEPEND=">=dev-lang/perl-5.6.1
+ virtual/perl-Time-Local
+ dev-perl/URI
+ geoip? ( dev-perl/Geo-IP )
+ ipv6? ( dev-perl/Net-IP dev-perl/Net-DNS )"
+DEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.1-gentoo.diff
+ epatch "${FILESDIR}"/${PN}-perl-5.22.patch
+
+ # change default installation directory
+ find . -type f -exec sed \
+ -e "s#/usr/local/awstats/wwwroot#/usr/share/awstats/wwwroot#g" \
+ -e '/PossibleLibDir/s:(.*):("/usr/share/awstats/wwwroot/cgi-bin/lib"):' \
+ -i {} + || die "find/sed failed"
+
+ # set default values for directories; use apache log as an example
+ sed \
+ -e "s|^\(LogFile=\).*$|\1\"/var/log/apache2/access_log\"|" \
+ -e "s|^\(SiteDomain=\).*$|\1\"localhost\"|" \
+ -e "s|^\(DirIcons=\).*$|\1\"/awstats/icon\"|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+
+ # enable plugins
+
+ if use ipv6; then
+ sed -e "s|^#\(LoadPlugin=\"ipv6\"\)$|\1|" \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ if use geoip; then
+ sed -e '/LoadPlugin="geoip /aLoadPlugin="geoip GEOIP_STANDARD /usr/share/GeoIP/GeoIP.dat"' \
+ -i "${S}"/wwwroot/cgi-bin/awstats.model.conf || die "sed failed"
+ fi
+
+ find "${S}" '(' -type f -not -name '*.pl' ')' -exec chmod -x {} + || die
+}
+
+src_install() {
+ dohtml -r docs/*
+ dodoc README.md
+ newdoc wwwroot/cgi-bin/plugins/example/example.pm example_plugin.pm
+ dodoc -r tools/xslt
+
+ keepdir /var/lib/awstats
+
+ insinto /etc/awstats
+ doins "${S}"/wwwroot/cgi-bin/awstats.model.conf
+
+ # remove extra content that we don't want to install
+ rm -r "${S}"/wwwroot/cgi-bin/awstats.model.conf \
+ "${S}"/wwwroot/classes/src || die
+
+ insinto /usr/share/awstats
+ doins -r wwwroot
+ chmod +x "${D}"/usr/share/awstats/wwwroot/cgi-bin/*.pl
+
+ cd "${S}"/tools
+ dobin awstats_buildstaticpages.pl awstats_exportlib.pl \
+ awstats_updateall.pl
+ newbin logresolvemerge.pl awstats_logresolvemerge.pl
+ newbin maillogconvert.pl awstats_maillogconvert.pl
+ newbin urlaliasbuilder.pl awstats_urlaliasbuilder.pl
+
+ dosym ../share/awstats/wwwroot/cgi-bin/awstats.pl /usr/bin/awstats.pl || die
+}
+
+pkg_postinst() {
+ elog "The AWStats-Manual is available either inside"
+ elog "the /usr/share/doc/${PF} - folder, or at"
+ elog "http://awstats.sourceforge.net/docs/index.html ."
+ elog
+ elog "Copy the /etc/awstats/awstats.model.conf to"
+ elog "/etc/awstats/awstats.<yourdomain>.conf and edit it."
+ elog ""
+ ewarn "This ebuild does no longer use webapp-config to install"
+ ewarn "instead you should point your configuration to the stable"
+ ewarn "directory tree in the following path:"
+ ewarn " /usr/share/awstats"
+}
diff --git a/www-misc/awstats/files/awstats-perl-5.22.patch b/www-misc/awstats/files/awstats-perl-5.22.patch
new file mode 100644
index 000000000000..8f4e1cac2c0b
--- /dev/null
+++ b/www-misc/awstats/files/awstats-perl-5.22.patch
@@ -0,0 +1,45 @@
+From 6ca56baf8e5819787c128e5ccd741701cb84bfdd Mon Sep 17 00:00:00 2001
+From: Laurent Destailleur <eldy@destailleur.fr>
+Date: Tue, 18 Aug 2015 20:41:20 +0200
+Subject: [PATCH] Compatibility with Perl 5.22
+
+---
+ docs/awstats_changelog.txt | 1 +
+ wwwroot/cgi-bin/awstats.pl | 12 ++++++------
+ 2 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/docs/awstats_changelog.txt b/docs/awstats_changelog.txt
+index 1fcca7f..1b5e342 100644
+--- a/docs/awstats_changelog.txt
++++ b/docs/awstats_changelog.txt
+@@ -8,6 +8,7 @@ New features:
+ option nboflastupdatelookuptosave on command line.
+ - #199 Added geoip6 plugin with support for IPv4 AND IPv6.
+ - Work with Amazon AWS log files (using %time5 tag).
++- Compatibility with Perl 5.22
+
+ Fixes:
+ - Fixes permission on some .pl scripts.
+diff --git a/wwwroot/cgi-bin/awstats.pl b/wwwroot/cgi-bin/awstats.pl
+index c9dcee9..eb14fc0 100755
+--- a/wwwroot/cgi-bin/awstats.pl
++++ b/wwwroot/cgi-bin/awstats.pl
+@@ -9040,12 +9040,12 @@ sub DefinePerlParsingFormat {
+ $LogFormatString =~ s/%>s/%code/g;
+ $LogFormatString =~ s/%b(\s)/%bytesd$1/g;
+ $LogFormatString =~ s/%b$/%bytesd/g;
+- $LogFormatString =~ s/\"%{Referer}i\"/%refererquot/g;
+- $LogFormatString =~ s/\"%{User-Agent}i\"/%uaquot/g;
+- $LogFormatString =~ s/%{mod_gzip_input_size}n/%gzipin/g;
+- $LogFormatString =~ s/%{mod_gzip_output_size}n/%gzipout/g;
+- $LogFormatString =~ s/%{mod_gzip_compression_ratio}n/%gzipratio/g;
+- $LogFormatString =~ s/\(%{ratio}n\)/%deflateratio/g;
++ $LogFormatString =~ s/\"%\{Referer}i\"/%refererquot/g;
++ $LogFormatString =~ s/\"%\{User-Agent}i\"/%uaquot/g;
++ $LogFormatString =~ s/%\{mod_gzip_input_size}n/%gzipin/g;
++ $LogFormatString =~ s/%\{mod_gzip_output_size}n/%gzipout/g;
++ $LogFormatString =~ s/%\{mod_gzip_compression_ratio}n/%gzipratio/g;
++ $LogFormatString =~ s/\(%\{ratio}n\)/%deflateratio/g;
+
+ # Replacement for a IIS and ISA format string
+ $LogFormatString =~ s/cs-uri-query/%query/g; # Must be before cs-uri