summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-25 06:22:01 +0100
committerSam James <sam@gentoo.org>2023-06-25 06:22:01 +0100
commite753fa7bb080e7ff8a0a76cd0ef8328562a48fbe (patch)
tree4f820e2fc715d5a26f93ec751229c6984748324a /www-servers/lighttpd
parentsys-devel/boost-m4: add 0.4_p20221019 (diff)
downloadgentoo-e753fa7bb080e7ff8a0a76cd0ef8328562a48fbe.tar.gz
gentoo-e753fa7bb080e7ff8a0a76cd0ef8328562a48fbe.tar.bz2
gentoo-e753fa7bb080e7ff8a0a76cd0ef8328562a48fbe.zip
www-servers/lighttpd: fix meson typo in src/
Closes: https://bugs.gentoo.org/905219 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-servers/lighttpd')
-rw-r--r--www-servers/lighttpd/files/lighttpd-1.4.69-fix-meson-typo.patch29
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.69.ebuild4
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.70.ebuild4
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.71.ebuild4
4 files changed, 41 insertions, 0 deletions
diff --git a/www-servers/lighttpd/files/lighttpd-1.4.69-fix-meson-typo.patch b/www-servers/lighttpd/files/lighttpd-1.4.69-fix-meson-typo.patch
new file mode 100644
index 000000000000..07e65091a08c
--- /dev/null
+++ b/www-servers/lighttpd/files/lighttpd-1.4.69-fix-meson-typo.patch
@@ -0,0 +1,29 @@
+https://github.com/lighttpd/lighttpd1.4/pull/127
+
+From 7445f72eb441052f7051f029b25d39855dc75e1c Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 25 Jun 2023 06:18:40 +0100
+Subject: [PATCH] src: Fix 'getoption' meson typo
+
+Bug: https://bugs.gentoo.org/905219
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -381,7 +381,7 @@ if get_option('with_gnutls')
+ # function: gnutls_check_version (-lgnutls)
+ libgnutls = [ dependency('gnutls') ]
+ conf_data.set('HAVE_GNUTLS_CRYPTO_H', true)
+- if not(get_option('with_openssl')) and not(get_option('with_wolfssl')) and not(get_option('with_mbedtls')) and not(getoption('with_nettle'))
++ if not(get_option('with_openssl')) and not(get_option('with_wolfssl')) and not(get_option('with_mbedtls')) and not(get_option('with_nettle'))
+ libcrypto = [ dependency('gnutls') ]
+ endif
+ endif
+@@ -402,7 +402,7 @@ if get_option('with_nss')
+ #libnss3 = [ compiler.find_library('nss3') ]
+ #libnssutil3 = [ compiler.find_library('nssutil3') ]
+ conf_data.set('HAVE_NSS3_NSS_H', true)
+- if not(get_option('with_openssl')) and not(get_option('with_wolfssl')) and not(get_option('with_mbedtls')) and not(getoption('with_nettle')) and not(getoption('with_gnutls'))
++ if not(get_option('with_openssl')) and not(get_option('with_wolfssl')) and not(get_option('with_mbedtls')) and not(get_option('with_nettle')) and not(get_option('with_gnutls'))
+ libcrypto = [ dependency('nss') ]
+ endif
+ endif
+
diff --git a/www-servers/lighttpd/lighttpd-1.4.69.ebuild b/www-servers/lighttpd/lighttpd-1.4.69.ebuild
index 942b36ef6672..d1ef39483fca 100644
--- a/www-servers/lighttpd/lighttpd-1.4.69.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.69.ebuild
@@ -72,6 +72,10 @@ BDEPEND="
test? ( virtual/perl-Test-Harness )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.69-fix-meson-typo.patch
+)
+
# update certain parts of lighttpd.conf based on conditionals
update_config() {
local config="${ED}/etc/lighttpd/lighttpd.conf"
diff --git a/www-servers/lighttpd/lighttpd-1.4.70.ebuild b/www-servers/lighttpd/lighttpd-1.4.70.ebuild
index d8c68c6d4ed0..5aa9f6dcb73d 100644
--- a/www-servers/lighttpd/lighttpd-1.4.70.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.70.ebuild
@@ -72,6 +72,10 @@ BDEPEND="
test? ( virtual/perl-Test-Harness )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.69-fix-meson-typo.patch
+)
+
# update certain parts of lighttpd.conf based on conditionals
update_config() {
local config="${ED}/etc/lighttpd/lighttpd.conf"
diff --git a/www-servers/lighttpd/lighttpd-1.4.71.ebuild b/www-servers/lighttpd/lighttpd-1.4.71.ebuild
index d8c68c6d4ed0..5aa9f6dcb73d 100644
--- a/www-servers/lighttpd/lighttpd-1.4.71.ebuild
+++ b/www-servers/lighttpd/lighttpd-1.4.71.ebuild
@@ -72,6 +72,10 @@ BDEPEND="
test? ( virtual/perl-Test-Harness )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.4.69-fix-meson-typo.patch
+)
+
# update certain parts of lighttpd.conf based on conditionals
update_config() {
local config="${ED}/etc/lighttpd/lighttpd.conf"