summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Michael <fedora.dm0@gmail.com>2021-01-11 11:15:23 -0500
committerMatt Turner <mattst88@gentoo.org>2021-01-18 16:09:59 -0500
commita486cc3851e20695da4c02d716aab87a50666c48 (patch)
tree52cc573cc7c5618fc8b63084afad6ebe32f0ac72 /x11-libs/colord-gtk
parentgnome-base/gdm: GLEP 81, EAPI 7 (diff)
downloadgentoo-a486cc3851e20695da4c02d716aab87a50666c48.tar.gz
gentoo-a486cc3851e20695da4c02d716aab87a50666c48.tar.bz2
gentoo-a486cc3851e20695da4c02d716aab87a50666c48.zip
x11-libs/colord-gtk: Version bump to 0.2.0
Signed-off-by: David Michael <fedora.dm0@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/colord-gtk')
-rw-r--r--x11-libs/colord-gtk/Manifest1
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild59
-rw-r--r--x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch41
3 files changed, 101 insertions, 0 deletions
diff --git a/x11-libs/colord-gtk/Manifest b/x11-libs/colord-gtk/Manifest
index 8c96fb2f5d33..5397459c0d55 100644
--- a/x11-libs/colord-gtk/Manifest
+++ b/x11-libs/colord-gtk/Manifest
@@ -1 +1,2 @@
DIST colord-gtk-0.1.26.tar.xz 280380 BLAKE2B 6ddd52b81726f21a2c376b1ab0c773f7670859882f3e5fe6038bf8728d5a9f3308b469b4e563dc784873b5b9cbed8ca671552e9bcb9cbccfaf28cd8f85e0b5bd SHA512 14f59110e2bc100c542323a68566102e9fb5ab44b679da21bf29101960dae38e646e926d884e14f1838a5991e6ebe15af72d5338723265868eadd5f026545c3d
+DIST colord-gtk-0.2.0.tar.xz 20480 BLAKE2B 73bbb349e84e5bfd28358cbe22609de84b86f90eb96a3fedc6e30a1764d9c667cd82408116cdf65591496ab4e2f59f2b415cd1aa8f995fe2162ee4d649c5d496 SHA512 797eebfd4451fcae4cf70835f5de3d9bdc9e8401ddb82a2fef2310002f28bf523b599c587ff35eb89ceff38a245a6311129ad90b107f837ac4f42f268c9aad97
diff --git a/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild b/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild
new file mode 100644
index 000000000000..d1ec57ccb2bc
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit meson vala
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="https://www.freedesktop.org/software/colord/"
+SRC_URI="https://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.28:2
+ x11-libs/gtk+:3[introspection?]
+ >=x11-misc/colord-0.1.27:=[introspection?,vala?]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/libxslt
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )
+ vala? ( $(vala_depend) )
+"
+
+RESTRICT="test" # Tests need a display device with a default color profile set
+
+PATCHES=(
+ "${FILESDIR}/${P}-optional-introspection.patch"
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local -a emesonargs=(
+ -Dgtk2=false
+ -Dman=true
+ -Dtests=false
+ $(meson_use doc docs)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}
diff --git a/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch b/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch
new file mode 100644
index 000000000000..543b443e3aec
--- /dev/null
+++ b/x11-libs/colord-gtk/files/colord-gtk-0.2.0-optional-introspection.patch
@@ -0,0 +1,41 @@
+From 0fb3425873a04ba100b57d59449d27bba6768ff3 Mon Sep 17 00:00:00 2001
+From: David Michael <fedora.dm0@gmail.com>
+Date: Sat, 9 Jan 2021 14:42:39 -0500
+Subject: [PATCH] Make introspection optional in meson
+
+It defaults to enabled to preserve existing behavior.
+---
+ libcolord-gtk/meson.build | 2 ++
+ meson_options.txt | 1 +
+ 2 files changed, 3 insertions(+)
+
+diff --git a/libcolord-gtk/meson.build b/libcolord-gtk/meson.build
+index c4fe704..18f36a0 100644
+--- a/libcolord-gtk/meson.build
++++ b/libcolord-gtk/meson.build
+@@ -61,6 +61,7 @@ pkgg.generate(
+ description : 'colord-gtk is GTK integration for libcolord',
+ )
+
++if get_option('introspection')
+ libcolord_gtk_gir = gnome.generate_gir(
+ colord_gtk,
+ sources : [
+@@ -97,6 +98,7 @@ libcolord_gtk_gir = gnome.generate_gir(
+ ],
+ install : true
+ )
++endif
+
+ if get_option('vapi')
+ gnome.generate_vapi(
+diff --git a/meson_options.txt b/meson_options.txt
+index 1c3cecc..a4efa84 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -1,4 +1,5 @@
+ option('gtk2', type : 'boolean', value : false, description : 'Build Gtk2 library')
++option('introspection', type : 'boolean', value : true, description : 'Build gobject-introspection typelib files')
+ option('vapi', type : 'boolean', value : false, description : 'Build vala bindings')
+ option('tests', type : 'boolean', value : true, description : 'Build self tests')
+ option('man', type : 'boolean', value : true, description : 'Generate man pages')