summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-10 09:17:37 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-10 10:11:25 -0400
commit1a5a9c324e72809e1cde1f5a3da6f332b0d57f82 (patch)
tree9367285a1b10f61b9678bf4ec20f339af0112b3b /x11-libs/libXt
parentx11-libs/libXfixes: Version bump to 6.0.1 (diff)
downloadgentoo-1a5a9c324e72809e1cde1f5a3da6f332b0d57f82.tar.gz
gentoo-1a5a9c324e72809e1cde1f5a3da6f332b0d57f82.tar.bz2
gentoo-1a5a9c324e72809e1cde1f5a3da6f332b0d57f82.zip
x11-libs/libXt: Version bump to 1.3.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libXt')
-rw-r--r--x11-libs/libXt/Manifest1
-rw-r--r--x11-libs/libXt/libXt-1.3.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libXt/Manifest b/x11-libs/libXt/Manifest
index dfbdc2fb53ef..d9d0de11c79a 100644
--- a/x11-libs/libXt/Manifest
+++ b/x11-libs/libXt/Manifest
@@ -1 +1,2 @@
DIST libXt-1.2.1.tar.bz2 784610 BLAKE2B 69a1446a22acb50e625ab4a7b24b5db634d47a540d4543a3f58459dbb380d61aa4bbbde50328c76b2c31eaae3662a1c71cdbcf9bd3a0c915ae4e587f63fbee7a SHA512 6877af61ba91eeed6b6f80471b84f354ad0ec0827249c7ee0a00c13508063fe8d2696dd400a4bdbc6ca2ff67cbe1317ad5ac24522fd96099dc56535e33ca052c
+DIST libXt-1.3.0.tar.xz 688084 BLAKE2B e8ac62bee544521471f25d3138b88d8d740bf8701aa7b6c1badcb9f725659c2648f3fd31813e0a05f1091514323bcea0788319cd36dfa945213f83cae87afb7c SHA512 64c5978655135b925c3aaad86b1aa6a3f3b57ad8b3592bf142be616b8aa339a02c2fc7badfab9564ea8076ea8f37acfe31709ed528f5a1d251f2d116aa074118
diff --git a/x11-libs/libXt/libXt-1.3.0.ebuild b/x11-libs/libXt/libXt-1.3.0.ebuild
new file mode 100644
index 000000000000..2672d4b45653
--- /dev/null
+++ b/x11-libs/libXt/libXt-1.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org X Toolkit Intrinsics library"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=x11-libs/libICE-1.0.8-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libSM-1.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ test? ( dev-libs/glib[${MULTILIB_USEDEP}] )"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_with doc xmlto)
+ $(use_enable doc specs)
+ $(use_enable test unit-tests)
+ --without-fop
+ )
+ xorg-3_src_configure
+}