summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarlson2k (Evgeny Grin) <k2k@narod.ru>2021-08-30 20:24:46 +0300
committerMatt Turner <mattst88@gentoo.org>2023-07-17 10:35:45 -0400
commitb0a3fe401ff1b9b01242774ee92653afd6e7d404 (patch)
treefef669839169b9c367572b18f5ce516694663c9e /x11-libs/libdrm
parentshell-completion.eclass: new eclass, migrated from ::guru (diff)
downloadgentoo-b0a3fe401ff1b9b01242774ee92653afd6e7d404.tar.gz
gentoo-b0a3fe401ff1b9b01242774ee92653afd6e7d404.tar.bz2
gentoo-b0a3fe401ff1b9b01242774ee92653afd6e7d404.zip
x11-libs/libdrm: add "udev" USE flag
udev support switches internal logic and does not require any external libs. Closes: https://github.com/gentoo/gentoo/pull/22163 Signed-off-by: Karlson2k (Evgeny Grin) <k2k@narod.ru> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libdrm')
-rw-r--r--x11-libs/libdrm/libdrm-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-libs/libdrm/libdrm-9999.ebuild b/x11-libs/libdrm/libdrm-9999.ebuild
index 195dc7c55c2b..592debf1d68d 100644
--- a/x11-libs/libdrm/libdrm-9999.ebuild
+++ b/x11-libs/libdrm/libdrm-9999.ebuild
@@ -26,15 +26,17 @@ for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done
-IUSE="${IUSE_VIDEO_CARDS} valgrind"
+IUSE="${IUSE_VIDEO_CARDS} udev valgrind"
RESTRICT="test" # see bug #236845
LICENSE="MIT"
SLOT="0"
-RDEPEND="
+COMMON_DEPEND="
video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
valgrind? ( dev-util/valgrind )"
+RDEPEND="${COMMON_DEPEND}
+ udev? ( virtual/udev )"
BDEPEND="${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/docutils[${PYTHON_USEDEP}]')"
@@ -44,8 +46,7 @@ python_check_deps() {
multilib_src_configure() {
local emesonargs=(
- # Udev is only used by tests now.
- -Dudev=false
+ $(meson_use udev)
-Dcairo-tests=disabled
$(meson_feature video_cards_amdgpu amdgpu)
$(meson_feature video_cards_exynos exynos)