summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-25 22:56:38 +0200
committerMatt Turner <mattst88@gentoo.org>2022-09-30 14:53:19 -0400
commit7ae77d2e82d6af70b987d0af802d8b9afea300a5 (patch)
tree689909c740b1de0d7ccecfd46e97818284fada48 /x11-libs/libwnck
parentprofiles: Mask >=gnome-base/gnome-desktop-43 (diff)
downloadgentoo-7ae77d2e82d6af70b987d0af802d8b9afea300a5.tar.gz
gentoo-7ae77d2e82d6af70b987d0af802d8b9afea300a5.tar.bz2
gentoo-7ae77d2e82d6af70b987d0af802d8b9afea300a5.zip
x11-libs/libwnck: Version bump to 43.0
Closes: https://github.com/gentoo/gentoo/pull/27454 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libwnck')
-rw-r--r--x11-libs/libwnck/Manifest1
-rw-r--r--x11-libs/libwnck/libwnck-43.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-libs/libwnck/Manifest b/x11-libs/libwnck/Manifest
index 4b6f2bdf51e9..db2f76fb7bae 100644
--- a/x11-libs/libwnck/Manifest
+++ b/x11-libs/libwnck/Manifest
@@ -1,2 +1,3 @@
DIST libwnck-2.31.0.tar.xz 630792 BLAKE2B 8201537d3c9a8a0a8668fc16d33a8eaa05c14312401f1c763c922402df04ef03260dd259f5c46508f85390f7aefd551e83143e654b24b412272dddb7c7c4bd62 SHA512 54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9
DIST libwnck-40.1.tar.xz 455624 BLAKE2B dd069cba299b9006a10de3311da87958f14a9defcc02a936cb0be38431eda9210aa8cff36ae63858235380a75c1d5266ce0612b5f93f47de21d48a5324af8a6d SHA512 50ba20547e95280d10f1f66f36eea6c649b59d385da7a9217c295150520099585a5ff43c08a552afb8b0db3ee7305bbb2c38d0baed84cc6dc0942f3ca1e43e29
+DIST libwnck-43.0.tar.xz 455464 BLAKE2B 591b7a9016f5149a2493d36ed8ec8a7e2a59b13043aed23bf87ef67520954d2e5cab0edb6f427c36f33fe80478ad363c9db6f4dacbc7c6d4295e79191e7f5043 SHA512 f6c14b0a650c6d5ab4d4013e6add3972a0f0bcdedfb9785f64199c9a65713d11c9d936e8b04d0f04707c3d165dd345bfa806f654bf82eabb765546b8914d68d2
diff --git a/x11-libs/libwnck/libwnck-43.0.ebuild b/x11-libs/libwnck/libwnck-43.0.ebuild
new file mode 100644
index 000000000000..32b8056b3e9b
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-43.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="https://developer.gnome.org/libwnck/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+
+IUSE="gtk-doc +introspection startup-notification tools"
+
+RDEPEND="
+ x11-libs/cairo[X]
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.22:3[X,introspection?]
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ x11-libs/libX11
+ x11-libs/libXres
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+"
+# libXi header used by wnckprop.c, which is compiled even with USE=-tools (just not installed then)
+DEPEND="${RDEPEND}
+ x11-libs/libXi"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ # Don't collide with SLOT=1 with USE=tools
+ sed -e "s|executable(prog|executable(prog + '-3'|" -i libwnck/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeprecation_flags=false
+ $(meson_use tools install_tools)
+ $(meson_feature startup-notification startup_notification)
+ $(meson_feature introspection)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}