summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-01-17 14:49:48 -0800
committerMatt Turner <mattst88@gentoo.org>2022-01-17 15:18:56 -0800
commit820b1427ea8786fdbb6c26a0615dcb7aad5d25b1 (patch)
tree0dbc0cd3bedd0d017351b1237ba7d47a21100e28 /x11-libs/libwnck
parentx11-wm/metacity: Version bump to 3.42.0 (diff)
downloadgentoo-820b1427ea8786fdbb6c26a0615dcb7aad5d25b1.tar.gz
gentoo-820b1427ea8786fdbb6c26a0615dcb7aad5d25b1.tar.bz2
gentoo-820b1427ea8786fdbb6c26a0615dcb7aad5d25b1.zip
x11-libs/libwnck: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs/libwnck')
-rw-r--r--x11-libs/libwnck/Manifest1
-rw-r--r--x11-libs/libwnck/libwnck-40.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-libs/libwnck/Manifest b/x11-libs/libwnck/Manifest
index af50f40d3ded..dc902c4aabcc 100644
--- a/x11-libs/libwnck/Manifest
+++ b/x11-libs/libwnck/Manifest
@@ -1,2 +1,3 @@
DIST libwnck-2.31.0.tar.xz 630792 BLAKE2B 8201537d3c9a8a0a8668fc16d33a8eaa05c14312401f1c763c922402df04ef03260dd259f5c46508f85390f7aefd551e83143e654b24b412272dddb7c7c4bd62 SHA512 54262a08882021f08f3ba7f2ddfa33fc1f02e391a0f61cf999a50a089e0d277dfe13ab133c1a46e9abf0599bd24c21dacff80b51013cbb1375d2cd71ac9abbe9
DIST libwnck-3.36.0.tar.xz 447760 BLAKE2B c61098362c57c3de879170d3104472b0a7f3c16da163c5d740d7a42bd545cfdaecd96804108834d5b7de5028e847f9b0557f015d08f50f9459a896f1d5f84431 SHA512 b7bf5d935327f61634a898594cf20a270e1b403c8df6c74e6ac20e22eea2845ac8c3007b31994728b74953e40c1015373efe10ed64243cf5e85fd210654aecb3
+DIST libwnck-40.0.tar.xz 455216 BLAKE2B 7ebadb2a57cd0ce6bccac265427cc31e9a84460219c2f19f9dd14c5e6175da19a2e8ab2309902e098686fb40bf277ae8b815d60b29b541de9992e0b1538f6777 SHA512 059f2a2add3f95feb7759e827072905652a4dc9c6756d526743319b5016ee36191b5c9a4fb5204f85a13049c2bd1bb3d01b2456ddb3ddc8f76148a0ee1651696
diff --git a/x11-libs/libwnck/libwnck-40.0.ebuild b/x11-libs/libwnck/libwnck-40.0.ebuild
new file mode 100644
index 000000000000..b8eedfea78f3
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-40.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson xdg
+
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="https://developer.gnome.org/libwnck/stable/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+
+IUSE="gtk-doc +introspection startup-notification tools"
+
+RDEPEND="
+ x11-libs/cairo[X]
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.22:3[X,introspection?]
+ startup-notification? ( >=x11-libs/startup-notification-0.4 )
+ x11-libs/libX11
+ x11-libs/libXres
+ introspection? ( >=dev-libs/gobject-introspection-1.56:= )
+"
+# libXi header used by wnckprop.c, which is compiled even with USE=-tools (just not installed then)
+DEPEND="${RDEPEND}
+ x11-libs/libXi"
+BDEPEND="
+ gtk-doc? ( >=dev-util/gtk-doc-1.9
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Don't collide with SLOT=1 with USE=tools
+ sed -e "s|executable(prog|executable(prog + '-3'|" -i libwnck/meson.build || die
+ xdg_src_prepare
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddeprecation_flags=false
+ $(meson_use tools install_tools)
+ $(meson_feature startup-notification startup_notification)
+ $(meson_feature introspection)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}