summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-01 12:35:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-01 13:15:43 +0200
commitf1ca943eb428edb09d045d7c4fa67af3c4040e1c (patch)
tree6151b236320cceb88f10dcd500810ef60d0c8b62 /x11-wm
parentdev-python/libcst: New package, v1.3.1 (diff)
downloadgentoo-f1ca943eb428edb09d045d7c4fa67af3c4040e1c.tar.gz
gentoo-f1ca943eb428edb09d045d7c4fa67af3c4040e1c.tar.bz2
gentoo-f1ca943eb428edb09d045d7c4fa67af3c4040e1c.zip
x11-wm/qtile: Bump to 0.25.0
Closes: https://bugs.gentoo.org/922707 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/qtile-0.25.0.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 5908b4193b7e..d37426707f8e 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1 +1,2 @@
DIST qtile-0.23.0.tar.gz 524536 BLAKE2B 9cf5b0cdffd7bc95ab7649827c221b20718f9dcc19b8ae2a50ceac5df3d71b117eef493a40523d81e60c8bc54b2103bc2a93775fcb20c025ec1dd84f9d809a19 SHA512 d6886df8efefacf90b1a5ec487c9a5a90414593900159213a218d638ef4f018b69284fe2cea707da12655a9736aad3df74a338a60344536e4d7eebcc9fc1090b
+DIST qtile-0.25.0.tar.gz 569312 BLAKE2B 3841ca41755f37191c659c039da45279393b5bbe94b3d532651548ba51d6dc62f3ac94cc5f3b02aa2b6c806e6bf97c9651756579b77938d133bdb1a697150626 SHA512 afd3267c70681d3656569f8ea88d02f35ab5d6baaa28b3d90f1b7552b5ed32c7d2f1f4f17272458ff2c39d0ca8f4fdb87748c9d7b4eb41031f3079126096c7d0
diff --git a/x11-wm/qtile/qtile-0.25.0.ebuild b/x11-wm/qtile/qtile-0.25.0.ebuild
new file mode 100644
index 000000000000..59ec0c0d2ac3
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.25.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=standalone
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi virtualx
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="
+ https://qtile.org/
+ https://github.com/qtile/qtile/
+ https://pypi.org/project/qtile/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="pulseaudio wayland"
+
+RDEPEND="
+ >=dev-python/cairocffi-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ dev-python/dbus-next[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-1.4.0[${PYTHON_USEDEP}]
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango
+ pulseaudio? (
+ dev-python/pulsectl-asyncio[${PYTHON_USEDEP}]
+ media-sound/pulseaudio
+ )
+ wayland? (
+ >=dev-python/pywlroots-0.16[${PYTHON_USEDEP}]
+ )
+"
+BDEPEND="
+ dev-python/cffi[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/libcst[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[X]
+ x11-base/xorg-server[xephyr,xvfb]
+ )
+ wayland? (
+ >=dev-python/pywlroots-0.16[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -e "s/can_import(\"wlroots.ffi_build\")/$(usex wayland True False)/" \
+ -i setup.py || die
+
+ # some tests expect bin/qtile
+ mkdir bin || die
+ cat >> bin/qtile <<-EOF || die
+ #!/bin/sh
+ exec qtile "\${@}"
+ EOF
+ chmod +x bin/qtile || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ local -x CFFI_TMPDIR=${T}
+ distutils-r1_src_compile
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # mypy stuff
+ test/test_check.py
+ test/migrate/test_check_migrations.py
+ # TODO: this test clearly requires x11 — so why is wayland
+ # variant being run?
+ 'test/backend/x11/test_window.py::test_urgent_hook_fire[wayland-2]'
+ )
+
+ # force usage of built module
+ rm -rf libqtile || die
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ nonfatal epytest --backend=x11 $(usev wayland '--backend=wayland') ||
+ die -n "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ insinto /usr/share/wayland-sessions
+ doins resources/qtile-wayland.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session-r1 ${PN}
+}