summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-29 16:16:58 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-29 16:18:15 +0100
commit9812b1e80c29245cb58e77aeab48e75e661200eb (patch)
treef09182c6ccc9c2dbd0e0b3ed93223e5e16907ac5 /xfce-extra
parentxfce-extra/xfce4-taskmanager: Bump to 1.5.7 (diff)
downloadgentoo-9812b1e80c29245cb58e77aeab48e75e661200eb.tar.gz
gentoo-9812b1e80c29245cb58e77aeab48e75e661200eb.tar.bz2
gentoo-9812b1e80c29245cb58e77aeab48e75e661200eb.zip
xfce-extra/xfce4-clipman-plugin: Bump to 1.6.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 5fcc749626c5..c3decaecbe61 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-clipman-plugin-1.6.5.tar.bz2 483621 BLAKE2B 0c13126a17e0fc668945b479dab3919b3f6e03a0ad378050041f40ddc4d0f138ffec128be779275eac637daf42352de4ac143d43d26cb8f40ac4d754d8ee70fb SHA512 b0ae4a3928590346dd0f9786959c138f7e9cc03afa974eee558890fcd2b96c019bd4be67f7c231cac802fb6356c64b1e0394ef327aae6256fc433ced245fdff9
+DIST xfce4-clipman-plugin-1.6.6.tar.bz2 487832 BLAKE2B 4d27c06c71c978680a2785db67262196293f1692fd82ba9cfdc2810b021dc83d8778243801e0766741e8f194a5aaa0573d5548443f6c3bfc9f7b970d7f102446 SHA512 4f6bb8f56111903af576d06ce5883e8ada2cb3ea377e09a79d2c5fb6f37743dac621649465a573a8a29a1fb884e7608a53dd6486eada23c7f8ee6401237988af
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild
new file mode 100644
index 000000000000..1e9a3da9e982
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X qrcode wayland"
+
+DEPEND="
+ >=dev-libs/glib-2.60.0
+ >=x11-libs/gtk+-3.22.29:3[wayland?,X?]
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.14.0:=
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXtst-1.0.0
+ )
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+ wayland? (
+ >=dev-libs/wayland-1.15.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? (
+ >=x11-base/xorg-proto-7.0.0
+ )
+ wayland? (
+ >=dev-util/wayland-scanner-1.15.0
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}