summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
index 2f14c001a891..b119b064ce72 100644
--- a/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.72-r2.ebuild
@@ -69,7 +69,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"