summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.75.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.75.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.75.ebuild b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
index 05bc1cd73145..ecc0a1b9d741 100644
--- a/net-dns/dnsmasq/dnsmasq-2.75.ebuild
+++ b/net-dns/dnsmasq/dnsmasq-2.75.ebuild
@@ -64,7 +64,9 @@ use_have() {
shift
while [[ ${uword} ]]; do
- uword=${uword^^*}
+ # Switch to ^^ when we switch to EAPI=6.
+ #uword=${uword^^}
+ uword=$(tr '[:lower:]' '[:upper:]' <<<"${uword}")
if ! use "${useflag}"; then
echo -n " -DNO_${uword}"