summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-05-30 21:13:32 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2012-05-30 21:13:32 -0400
commit16f1a056b0c2c4d11f3b77975008131620b0f795 (patch)
tree82045ba596909c315f33706c375796359bea65bb /app-editors
parentInitializing the git overlay profile/repo_name (diff)
downloadArmageddon-16f1a056b0c2c4d11f3b77975008131620b0f795.tar.gz
Armageddon-16f1a056b0c2c4d11f3b77975008131620b0f795.tar.bz2
Armageddon-16f1a056b0c2c4d11f3b77975008131620b0f795.zip
Git version of vim-qt ebuild draft added to the tree.
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/vim-qt/Manifest1
-rw-r--r--app-editors/vim-qt/vim-qt-9999.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/app-editors/vim-qt/Manifest b/app-editors/vim-qt/Manifest
new file mode 100644
index 0000000..890a69d
--- /dev/null
+++ b/app-editors/vim-qt/Manifest
@@ -0,0 +1 @@
+EBUILD vim-qt-9999.ebuild 1690 RMD160 d3cd7330197a325a1c24ed0a8a2eea627b2833d0 SHA1 253bb06f2ef50f248f32edaa91715aeafd9bb620 SHA256 c5bdb480b27a6a91fdcedf108a49b5ebcd62e9f2b6677db04e80ee733cb9c610
diff --git a/app-editors/vim-qt/vim-qt-9999.ebuild b/app-editors/vim-qt/vim-qt-9999.ebuild
new file mode 100644
index 0000000..56e5b6f
--- /dev/null
+++ b/app-editors/vim-qt/vim-qt-9999.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit toolchain-funcs git-2
+
+DESCRIPTION="Qt GUI version of the Vim text editor"
+HOMEPAGE="https://bitbucket.org/equalsraf/vim-qt/overview"
+EGIT_REPO_URI="git://gitorious.org/vim-qt/vim-qt.git
+ https://gitorious.org/vim-qt/vim-qt.git"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls acl cscope debug gpm perl python ruby"
+
+DEPEND="
+ >=app-admin/eselect-vi-1.1
+ >=sys-apps/sed-4
+ sys-devel/autoconf
+ >=sys-libs/ncurses-5.2-r2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ nls? ( virtual/libintl )
+ cscope? ( dev-util/cscope )
+ perl? ( dev-lang/perl )
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ ruby? ( =dev-lang/ruby-1.8* )
+ !<app-vim/align-30-r1
+ !<app-vim/vimbuddy-0.9.1-r1
+ !<app-vim/autoalign-11
+ !<app-vim/supertab-0.41
+ >=x11-libs/qt-core-4.7.0:4
+ >=x11-libs/qt-gui-4.7.0:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ use debug && append-flags "-DDEBUG"
+
+ myconf="--with-features=huge \
+ --enable-multibyte"
+ myconf="${myconf} `use_enable gpm`"
+ myconf="${myconf} `use_enable perl perlinterp`"
+ myconf="${myconf} `use_enable python pythoninterp`"
+ myconf="${myconf} `use_enable ruby rubyinterp`"
+ myconf="${myconf} `use_enable nls`"
+ myconf="${myconf} `use_enable acl`"
+ myconf="${myconf} --enable-gui=qt --with-vim-name=qvim --with-x"
+
+ if ! use cscope ; then
+ sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || \
+ die "couldn't disable cscope"
+ fi
+ econf ${myconf} || die "vim-qt configure failed"
+}
+
+src_install() {
+ dobin src/qvim
+}