summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim-qt/vim-qt-9999.ebuild')
-rw-r--r--app-editors/vim-qt/vim-qt-9999.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/app-editors/vim-qt/vim-qt-9999.ebuild b/app-editors/vim-qt/vim-qt-9999.ebuild
index 8b65058..330a462 100644
--- a/app-editors/vim-qt/vim-qt-9999.ebuild
+++ b/app-editors/vim-qt/vim-qt-9999.ebuild
@@ -21,12 +21,12 @@ DEPEND="
>=sys-apps/sed-4
sys-devel/autoconf
>=sys-libs/ncurses-5.2-r2
- gpm? ( >=sys-libs/gpm-1.19.3 )
- nls? ( virtual/libintl )
- cscope? ( dev-util/cscope )
- perl? ( dev-lang/perl )
- acl? ( kernel_linux? ( sys-apps/acl ) )
- ruby? ( =dev-lang/ruby-1.8* )
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ nls? ( virtual/libintl )
+ cscope? ( dev-util/cscope )
+ perl? ( dev-lang/perl )
+ acl? ( kernel_linux? ( sys-apps/acl ) )
+ ruby? ( =dev-lang/ruby-1.8* )
!<app-vim/align-30-r1
!<app-vim/vimbuddy-0.9.1-r1
!<app-vim/autoalign-11
@@ -40,21 +40,21 @@ src_configure() {
use debug && append-flags "-DDEBUG"
- myconf="--with-features=huge \
+ myconf="--with-features=huge
--enable-multibyte"
- myconf+="$(use_enable gpm)"
- myconf+="$(use_enable perl perlinterp)"
- myconf+="$(use_enable python pythoninterp)"
- myconf+="$(use_enable ruby rubyinterp)"
- myconf+="$(use_enable nls)"
- myconf+="$(use_enable acl)"
- myconf+="--enable-gui=qt --with-vim-name=qvim --with-x"
+ myconf+=" $(use_enable gpm)"
+ myconf+=" $(use_enable perl perlinterp)"
+ myconf+=" $(use_enable python pythoninterp)"
+ myconf+=" $(use_enable ruby rubyinterp)"
+ myconf+=" $(use_enable nls)"
+ myconf+=" $(use_enable acl)"
+ myconf+=" --enable-gui=qt --with-vim-name=qvim --with-x"
if ! use cscope ; then
sed -i -e '/# define FEAT_CSCOPE/d' src/feature.h || \
die "couldn't disable cscope"
fi
- econf ${myconf} || die "vim-qt configure failed"
+ econf ${myconf}
}
src_install() {